Netflix - Something Went Wrong error EVERY show

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
raked
Resident
For whatever reason, I can't watch any show on Netflix on Telus Optik TV. Every selection I make gives me the Something Went Wrong error. Why?? How do I fix this?? Netflix is working fine on PS3 so it can't be my Netflix account...
Community Power User
Community Power User
Try a power cycle on your receiver. (Unplug it wait 10 seconds, then plug it back in).

Do you have more then one receiver? Do others have the same symptoms? Which model(s) do you have? Has Netflix ever worked on your optik box? Have you changed any settings in the router, DNS?


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Bob3
Resident

We are having the same problem and have been bounced back and forth between TELUS and Netflix three times.  Did you ever resolve you prolem?

Community Power User
Community Power User
Have you tried what I stated above yet?

Are you using an alternative DNS server in your modem?

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
PaulJT
Connector

I'm getting the "something went wrong" error, but only on a couple of titles when I try to watch on my Telus box. It happens to be Amy Schumer and Louis CK's new standup specials. Some pertinent info:

  • I can watch them on my iPhone and my PC
  • I tried power cycling the telus pvr
  • I tried logging out of Netflix then back in again and trying.
  • I don't use an alternate DNS server, everything is set up the way Telus left it.

 

Community Power User
Community Power User
@PaulJT what titles specifically are you running into issues with? I would like to see if not playable for me as well. Or if an isolated issue for your setup only.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
PaulJT
Connector
Ridiculous, after all these weeks and finally asking for help they just started working. Sigh
Thanks for offering to help