Showing results for 
Show  only  | Search instead for 
Did you mean: 

Initializing digital box

Just Moved In
My secondary wireless optik box said it needed to initialize so I put it through the paces. Now it's stick on the "this will only take a moment" screen forever and forever. I've tried all the suggested steps. Powering down, unplugging and restarting the main box, same result. Very frustrating


How long did you wait (minutes)?

Sometimes it does take a long time (over 10 minutes) and sometimes it's quicker. I haven't figured out why or when.


Try rebooting in this order:

  1. Router
  2. PVR
  3. other Optik boxes

Community Power User
Community Power User

Contact Telus. They will take you through the steps. It usually includes re-starting your Router, as well as the set-top box, and is a multi-step process.


If I recall:

Turn off both the router and box

Wait 10 minutes

Restart router and wait for it to boot

Start box

Press WPS on router

accept WPS on box

restart box



If you find a post useful, please give the author a "Kudo"