Showing results for 
Show  only  | Search instead for 
Did you mean: 

Can't manage my package selection through the website or the Telus app


I've been trying to change my OptikTV selection for the past week with no success. The website loads fine but then it gets stuck in a perpetual loop then gives me an error telus-1.JPGtelus-2.JPGScreenshot_20231011_231903_My TELUS.jpg

I've tried on different browsers - Chrome, Firefox, Edge with the same results. Disabled all browser extensions and plugins. On mobile, I've forced stopped the app, cleared cache and as a last result just straight reinstalled it but it gives me the same error every time.


Community Manager
Community Manager

@Noobie two issues that I can think of off the top of my head:

1) Are you a new customer? Sometimes it can take one full bill cycle before the option is enabled online

2) Account/payment related. There could be a limitation on certain accounts relating to their status. For this issue, we wouldn't be much help on community since it requires agent intervention.

Of course, there could be a technical issue also but these tend to be rare. Can you confirm #1 for me?

1) No, not a new customer.

2) Paid for this month so no issues on that front.

Community Manager
Community Manager

Hey @Noobie is the email used to register here on the Neighbourhood community the same that's on your Home Services account? We'd like to share this with our team for further investigation!

Did you follow up for a solution to this. We would really like to manage our internet and optik tv through My Tellus? Tried all of the supposed solutions. Resetting, restarting, updating etc. Windows 10 laptop and Samsung tablet with app.


On the weekend I went through Facebook chat and since it was no help asked for a callback. I got the call the next day from an administrator who promised to forward a ticket to tech and that they would be in touch. Today Wed Nov 1 suddenly I can now manage my Optik TV but still can not manage my internet on My Telus on my laptop. Perhaps this will be fixed soon as well. I was told that this forum is not regularly responded to and the best way is to go through Facebook Messenger. I have still not received a call back.


Today, Monday,  I can not manage Optik TV or Internet and though I got a call back on Thursday they said that yes we are having technical issues with this and that they would forward a ticket again. As of today no call back and still an issue. WTH



I have the same issue and have been dealing with it for a few months now with no resolution.  It has now gotten worse because I also cannot manage Internet service any more.  I always get the "Looks like something went wrong.  Please try again." message every time.  I have had several conversations with support, they were able to replicate the issue on their end, but no fix.  No issues with the account or anything, and no service issues.  I have been with Telus for about a decade or maybe more...

Based on my Google PlayStore review, I've been having this problem for at least a year and a half:

Screenshot 2023-10-27 094348.png


I have the same issue with managing internet and Optik and just get the "Something went wrong. Try again" message. Good to know that asking for a technical fix provides not solutions so I do not waste my time trying. Confused whether this is intentional or not?



Add me to the list as well.


I remember being able to delete/add Optik TV channels/packages online. In fact, Telus's help still refers to being able to do so.


Now, it takes 1hour 20 minutes (and counting) to talk with a pleasant customer service rep in the Philippines to make simple changes.


Telus: please re-enable online Optik TV management and respect my time.

It was probably taken down to get the bugs out of it since it failed to complete an order.


I'm facing the same challenges on their website and Telus app. I consistently see the same error message: "Something went wrong. Try again" OR "Sorry, we are experiencing trouble connecting to the server this time...." and calling their support desk is a profound waste of time. 

Same problem over here. Both on the website and in the app. Super frustrating as there was a hockey game on tonight that we wanted to watch, but haven’t been able to add the channel or change our theme packs. Scheduled a call back through the chat in the all but got a call from Tech support who obviously couldn’t help. Then they transferred me to the CLOSED customer service line. Super helpful 🙄