Welcome to the (Shiny New) Neighbourhood

ScottyJ Neighbourhood Alum
Neighbourhood Alum
After months of planning, we're very excited to unveil our newly redesigned Neighbourhood online community! We've cooked up some changes that we're really proud of, and have set the stage for more to come.
 
Obviously, everything has been visually refreshed. This is give a common look and feel between what's here and what's on the main TELUS.com site, as well as responsive display, so that the best of the Neighbourhood experience is optimized for phone and tablet screens.  We've also tried to make navigation clearer between the sections (forums, ideas, blog).
 
In the Forums, answers can now be marked as "Most Helpful" (instead of "Accepted Solution") to help everyone understand what's best, and we've cleaned up the cluttery stuff. Also, email notifications that let you know about replies and mentions now allow you to "Like", "Reply", or "Mark as Most Helpful" right from the email! The future is now!
 
What else is different? Well, we've added this blog as a way to talk about the goings on in the Neighbourhood, and as another way to keep conversations going. We've also added a few boards in the forums to help people find the kind of content they need most where it comes to mobile devices (we're moving threads around to help).
 
But wait, there's more! This new design will propel a new gamification construct coming in the next few months. Yes, all our Neighbourhood citizens have been earning ranks for their participation, but we'll be refining how the ranks are earned, sharing that, and adding badges, too! Lastly, we'll be adding a section for articles, where the best and most useful forum posts and idea responses will be curated for easy finding and sharing.
 
This all comes down to trying to make it easier and more fun for people to gather, share, and contribute in the TELUS Neighbourhood. I hope you enjoy what we're building here, and would love to hear thoughts, reactions, and feedback!
50 Comments
Community Power User
Community Power User

I've posted a list of bugs and errors that may need attention.


http://forum.telus.com/m/compose/My_Home_Account?message_id=49519

ScottyJ Neighbourhood Alum
Neighbourhood Alum

There are far more than that Smiley Happy We've gone live a little earlier than intended, so we're working through the rest of the changes necessary to make sure everything is tickety-boo.


Exciting times when things move fast.

Community Power User
Community Power User

Correct URL: http://forum.telus.com/thread/id/49519


The little drop down menu is broken on this blog post so editing is not possible. (Firefox, Chrome)

Community Power User
Community Power User

And the forum keeps breaking the URLs... The above URL is the link to the post but it keeps generating File Not Found message when trying to view it, or even when reloading the post itself. You can find my post under the My Home Account forum.

ScottyJ Neighbourhood Alum
Neighbourhood Alum

Okay, most all links should be working now, and elements are coming together. We'll be watching closely for bugs and defects, and are continuing to work on more features and functions to come soon.


Thanks for your patience, everyone, and I hope you enjoy a stroll around the new Neighbourhood!

Shane
Ambassador

My settings are not being saved in the New Neighbourhood. In Notification Settings I click "Show all activity", and in Privacy settings I clear "Show my email address publicly". However, the next time I come back to my Settings, the changes I made are gone.


Shane.

Dark_Knight
Rockstar

test

Dark_Knight
Rockstar

I can't at-mention anymore in my posts. It will not actually post the reply if I include one. 

Community Power User
Community Power User

Can't stay logged in either. If I close the tab I had the forum in while logged in and return some time later, I'm logged out and have to log in again. Also if you are not logged in and click the link above the Reply box to log in, the forum gets stuck and all you see is "Loading the neighborhood.." non-stop. You guys really need to kill a good chunk of the javascript being used. It's buggy and slow.

Community Power User
Community Power User

PS: Loading the site on mobile ate 1.6MB of data just to load the front page. That is a huge amount of data for a responsive site. One of the damaged javascript files also was causing problems. it's also the one that's 785kb in size. (angular.js)

ScottyJ Neighbourhood Alum
Neighbourhood Alum

Thanks for the reports, everyone. We're still on the case of tracking issues and fixes, so appreciate you letting us know your finds!


ScottyJ

Doug1Ames1
Ambassador

Wow, this is so much better than the old version - you know, the one that actually worked?


No need to bother with supporting that pesky Firefox browser any more, everyone can just use Chrome and like it! And if it takes several minutes to log in and keeps forgetting users, well, people need to slow down and smell the roses a bit.

Doug1Ames1
Ambassador

Do you think you could make the font in the forum topics list A BIT BIGGER? I don't think you've got it huge enough yet!

ScottyJ Neighbourhood Alum
Neighbourhood Alum

 @Doug1Ames1 Still working through issues and changes. What issues are you seeing in Firefox? I'd love to make sure we identify every bug so that we can get them sorted. Appreciate it!

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@Doug1Ames1 Font size is being discussed for sure - it's a balance between form and function, where we want to create an experience that is complementary to telus.com, but also address usability here.

 

There will be a lot of changes as we're taking an iterative approach, so keep the feedback coming. What you see isn't carved in stone Smiley Happy

Community Power User
Community Power User

New bug found. The comments posted here are appearing in random order now. First comment showing here is 3 hours old, followed by 16 hours old, then 24 MINUTES old. Makes it hard to read the comments in order. If I load the forum in another browser, the comments are in yet a different order again but still not chronological.

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@Nighthawk Ticket opened. Thanks!

v9
Rockstar

From <v9> I welcome any improvements on the [FORUM-Interface] As I've said in other boards the change it has some (shiny-new features) like the Female-Male-picture a lot animated, creatures like fishes, birds+animals also.

 

But they scrapped it some basic typing tools: Like Italized, Under_line-No PM neither SpellCkecker features,.Doesn't show a full list of the top authors, only shows 5members no option to "View All" In resume we hope the management take in acct--our concerns & keep essential tools to [Write+Edit our scripts]. Tha's all let's wait for those changes. Bye <v9>

nasty
Rockstar

All I can say is,  UGLY.

The old forum was plain, but thats what forums should be.


Should of built the new forum along side of the old forum, in a hidden admin-beta, to be sure all settings are 99% done on the change over day.  At rollout, you do a data transfer over, and near perfection. 


Community Power User
Community Power User

@Doug1Ames1

@nasty


I'm guessing there was a change of plans somewhere along the way, and Telus took the redevelopment in-house. I'm also guessing a contract with their software platform provider (Lithium) may have expired, causing a release of the new forum before it was complete, and the Telus team is scrambling to bring it together. 


In the meantime, while sarcasm and hyperbole have their place, maybe we should be supportive of the efforts being expended here, even though we have some frustrations with the interface. Lets offer constructive suggestions which can be acted upon by the development team.


NFtoBC

(Just a user of Telus services)

Community Power User
Community Power User

New bug found. The comments posted here are appearing in random order now. First comment showing here is 3 hours old, followed by 16 hours old, then 24 MINUTES old.


@Nighthawk


I'm not seeing this behaviour in Safari. Possibly different browsers are rendering differently?


Also, I miss the reverse chronological order (newest first) which was the previous default.


NFtoBC



ScottyJ Neighbourhood Alum
Neighbourhood Alum

@NFtoBC Thanks for the kind words.

 

I'm not going to go in to any kind of gruesome detail about what's what with contracts and the like, but really, it's much simpler than that. We wanted a new site that aligned to all the work that's been done with telus.com, and which would set us up to launch some new features.

 

There hasn't been a strategy change or contract expiry or any shuffling of who does what. Our intent was to launch fast, get feedback, and iterate. As such, yes, what we have today is missing some things (private messaging), and there are a bunch of defects (actively being worked).

 

Now, like I said, a change was made that launched us earlier than we had planned or were ready for. Woops. But we're rallying everyone and working hard to both identify and retire bugs as fast as we can.

 

While we do, please keep all the feedback coming! I'm recording all of it. Some things are bugs that we're squashing right away (comments out of order), some things are design change feedback that we're considering how we'll address (font sizes), and some things are everywhere in between.

 

Just know that (and this is one of the main reasons for the Neighbourhood in the first place) we're hearing all of this, and while some of it is hard to hear, we get it, and we're working to continue to improve everything.

 

What we have today isn't the be all and end of development. We're going to keep iterating and keep improving. Thanks to everyone for contributing. You help make everything better.

Community Power User
Community Power User

@ScottyJMicrosoft once released a system fast too. It was called Windows Vista. This is how I view the forums now. Far to rushed to market. Far too many bugs and far too many design and coding issues.


New bugs

  • Google has URLs of all the old content cached. When searching anything Telus related they come up and now every single link is broken with the forum change. 
  • On mobile: when clicking to view the next page of comments the forum loads them but drops the user to the bottom of the pag . Bad code. 
xlxo
Helpful Neighbour

All I can say is,  UGLY.

The old forum was plain, but thats what forums should be.

I'm going to have to agree with Nasty....  The new forum is very slow as it chews up bandwidth.  Especially hard for those using their smartphones to participate.  I guess this is one way Telus is pushing users to bigger plans?

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@Nighthawk Both bugs tracked and being worked - thanks!

 

@xlxo Pushing data usage is not the case at all. We're working on optimizing, and we're making changes constantly to address defects as well as to make the experience smoother.

 

I think the key thing we're working towards is balance, with three factors in play:

 

  • Content ingestion from casual visitors
  • Content creation from contributors
  • An aligned experience with telus.com

In a lot of ways, the best elements to serve these three needs are contradictory. We're experiementing and learning, and we're changing as we go. We are iterating over what you see today, so it's going ot continually evolve and improve thanks to everyone's feedback.

 

So please keep the feedback coming!

Doug1Ames1
Ambassador

The problem with Firefox turns out to be that my ad blocker automatically blocks Omniture, which is the tracker you have on your landing page. For some reason that results in a blank page. If I temporarily enable that tracker, it's ok once I get past the landing page.


Back to Chrome, logging in to post a comment takes several minutes and a couple of refreshes. And it doesn't remember me for next time when I check the box.

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@Doug1Ames1 That Firefox one is an interesting one - Omniture was used in our previous site, too, so there must be a differrence in implementation. I've got this logged. Which ad blocker are you using? (So that we can test).

 

I'll log something for Chrome, and we're working on the "Remember Me" piece, too.

 

Thanks!

Community Power User
Community Power User

You guys should really go check out how Shaw has their forums. You do NOT need them to look like the main page of Telus.com (which has over-sized fonts too) to have a functional community. If Telus wants to see a consistent design throughout that is more user friendly, see what Bell has. Consistent visual theme, reasonable sized fonts, very easy navigation and it just looks good. Telus.com is a navigational nightmare. The new forums are much worse.  Even the most evil company in Canada, Rogers, isn't nearly as bad. They are still using the old forum software Telus was using too.


Additional issues:

  • The Telus logo at the top of the site directs users to forum.telus.com. This is inconsistent with the rest of the site where it goes to Telus.com. If Telus wants a consistent design, fix that, add a support/forums menu item at the top of the site.
  • When typing responses in Chrome (newest) on Android 4.4.4, some letters at the end of words or sentences randomly disappear.
  • Unable to remove or edit links attached to text when creating a forum post / response.
  • After re-evaluating - font size on mobile devices is too large. Text for menu items / forum headings is wrapping to the next line (1080p display). The images next to the forum headings on the front page are also too large.


Here is an example some of the thousands of now broken links to the Telus forum with the new software. These links are all specifically from the Telus Forums as they tend to show up near the top, if not at the top, of search results:

I'm sure you can guess how many other possible searches users can do and how many results are now broken. Telus shot themselves in the foot with this one and made it harder for users to find answers as a result of using a search engine.

nasty
Rockstar

@Doug1Ames1"ad blocker automatically blocks Omniture"  https://en.wikipedia.org/wiki/Omniture

------------------------------


Odd. I don't see any sign of that tracker. Not page source and not AdblockPlus. 


ScottyJ Neighbourhood Alum
Neighbourhood Alum

@Nighthawk Keenly aware of the approach others take/have taken. We're trying some new things here. Like you've said, there's some room for improvement, and we're using all the feedback. The way things are isn't the way they will forever be. Smiley Happy


Totally hear you on the change in URL schemas, and we're working to catch and redirect them all. Google is a huge driver of traffic, and we know how valuable the content everyone has contributed is, so we want to make sure people both find and get to it.


We're re-looking at font sizes across the board, so expect some changes there.


For the link editing/removal, yes we have a simplified WYSIWYG editor right now, but we're looking at how we expand it. Thanks for flagging this, I've added your vote to this.

Doug1Ames1
Ambassador

I'm using Ghostery as an ad blocker in Firefox. It lists the trackers found on each page in a little pop-up box as it blocks them. (Firefox 33.1.1 and Ghostery 5.4.1). Omniture appears one time on the first access to the forums, and if it's blocked then the site won't load. If it's allowed once, then it doesn't appear again or block loading future pages - until there's a new login, which causes it to appear one time again.


Login is equally slow in Firefox and Chrome, and I think I'd be looking at a spinning circle forever if I didn't refresh the page at least once to wake it up.

nasty
Rockstar

Oh, OK. I see its a bit hidden. I clear my cookies(especially the mass of first-party Telus cookies) after forum logouts, while blocking third party cookies too.


The code

forum.telus.com/lib/telusforum_s_code.js?version=


Ghostery test on Linux and Windows , Firefox, (current), and both load with it blocking the tracking bug.  The script that generates the new forum is a touch slow. Slow enough to see it loading parts, but not waiting slow.


Community Power User
Community Power User

The ability to report spam is broken too. Considering the spammers that keep returning, it's something that needs to be fixed. There are two spam posts under http://forum.telus.com/thread/id/5705 currently linking to known spam sites.

Community Power User
Community Power User

Drop down (edit, report etc) broken in this forum; works in some others.


Choosing previous or next to move through pages takes you to the top of the appropriate page; choosing the numbers most often takes you to the bottom of the page chosen.


NFtoBC

Community Power User
Community Power User

New bug: Every time I log in, the number of "new" replies on all threads seems to reset as if I've never read any of them.

xlxo
Helpful Neighbour

Latest activity needs to show something like 15 to 30 items, not 3 items.  Latest activity should allow for RSS like the previous version.

xlxo
Helpful Neighbour

Ugh.... can't edit responses like the old version.

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@xlxo Totally agree on latest activity. Putting in a change for that. Response editing should work, though? Which platform/browser are you using?

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@xlxo Oh hm, that's weird, you're right the menu isn't working on blog comments (does work in forum, though). I'll get a ticket opened - thanks for the heads up!

xlxo
Helpful Neighbour

With regards to "latest activity".  I think you can list 20 items in there by reducing the font size without radically changing the look to the rest of the webpage.

v9
Rockstar

ATTENTION @ScottyJ - We thank you for quickly replies, something that other ADMIN didn't do it. Regarding to the last post activity..in the New forum-Interface. 1) Is showing this right now:: [RollBack To Older Version 1.0 - Posted by <v9> abaut 9 hrs. Ago  10-Replies] is displayed "Twice" unbelievable, how come in simple settings, the "Designer Team Failed" PS review the bug & apply a steady fix.

 

2) As pointed out in my post. Basic features were removed, but I'd compressed in 2-3 that need Urgent Attention. Return the older layout of the Posts' VIEW like: [Post Title--Replies--New--Author--Likes--Views--Lates reply] or Added at the New-Interface and I guarantee that-You'll receive Kudos for it.

 

b) RETURN the Removed tools to the new Typing field: [Italized, Underline, Emoticons, Familiar font, Font size, Text colour icon & Spellckecker]. Also on the Options-top right corner the tools [Edit, Print, Hightlight,.Etc.] were removed, get them back would be great.

 

3) RETURN or Modify the Top Members View in ea. Board-Just add the link <View all> as before & done deal.

Important fix the issue, with LOG IN the new Forum ver. Known cases,.xl-v9 ++more than 10 other members, who have "NIcks with 2-Characters" are UN-Able to Sign IN the new "Shiny-Neighbourhood" I'll stop here & wait for the Fixes <v9>

ScottyJ Neighbourhood Alum
Neighbourhood Alum

@v9 all of the things you have listed here are on our radar to be addressed, except spellchecker, as we think a browser/OS-based spell check makes more sense for check-as-you-type and a consistent experience with other apps/webpages. Thanks for the list!

Community Power User
Community Power User

xl(xo) said: "With regards to "latest activity". I think you can list 20 items in there by reducing the font size without radically changing the look to the rest of the webpage."


Possibly a scrolling text box could be used for this? I, too would like to see a more comprehensive "Latest Activity" list or view.

Community Power User
Community Power User

The 'My Mobility Account' section seems to promote a newly replied topic to the top of the list, and reference it on the front page, but does not accurately reflect the most recent comments, commenter, or date of recent comment. A comment made a few minutes ago moves the topic to the top, and to the front page, but still references a long past date as the time of the update on all pages EXCEPT the topic discussion page itself.


NFtoBC

Dark_Knight
Rockstar

I could finally change my display photo! To use a Charlie Sheen phrase, WINNING! 


I think the mobile site is badass. I also like how it shows up on tablets, but I do not love the desktop version. The layout and UI are off.


Thanks for fixing the bugs so quickly.

Dark_Knight
Rockstar

Something is definitely awry with the editing. It shows up in HTML or something. Please fix that. 

xray
All-Star

Link in email notification takes me to old site. Not sure if this is just a to-do that hasn't been done yet or a real bug. It was a "most helpful" notification if that makes any difference.

ScottyJ Neighbourhood Alum
Neighbourhood Alum

Thanks, @xray - it's on the list Smiley Happy I think that might even be sorted today.

Wackier
Just Moved In

can I change my display name?

ScottyJ Neighbourhood Alum
Neighbourhood Alum
@Wackier Send me a private message (messages are accessed from your avatar's menu) and I can help with that.

Cheers,

ScottyJ