cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to top-up with voucher

BenCox
Neighbour
So I'm currently in the UK with my phone which does not roam internationally, I had a friend purchase a top up voucher for me and send me the pin so I could apply it on my iPad telus app, it comes back with an error, so I tried the my mobility website top-up, again error with telus system, cannot complete at this time.
I'm not sure sure what to do next, I need to top up this phone or I will lose my number, any ideas?
Thanks in advance.
5 REPLIES 5

Nighthawk
Community Power User
Community Power User

I've never tried a voucher while outside of Canada. Could be some kind of limitation maybe? I'd suggest chatting with Telus online. They may have an easy solution. 

 

http://www.telus.com/chat

 

🙂


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Thanks nighthawk, I'll try that a bit later, currently no chat agents are online, (time difference)
Hopefully that will resolve the issue.

You can also reach out to them over twitter @TELUSsupport 🙂

Thanks, I was able to get the issue resolved, I continuously received the no agents available on the live chat.
I was able to use text+ app to phone telus' international number free of charge and spoke to an agent there.
Great customer service, they had accidentally closed my account earlier than stated.
The agent reactivated at no cost, applied the credit and extended the expiry date, all within 5 minutes.

Thank you all for your help also, I appreciate it.

Thread can be closed thanks.

Thanks for the update @BenCox. Glad to hear you got your issue resolved. All too often posters don't take the time to report back the solution for the benefit of others who may be in the same boat.