Can't get into account

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
amberkup
Resident
I tried making an account and didn't have my account number so a few days later after figuring out my account number I tried making a new account again but it said my email was already registered. So I tried logging in using my email and password I had tried the first time and it brings me into my account, says "welcome back [name]" and says I'm on step 2 of my registration. But then it just keeps trying to load that page and I can't do anything in my account. I've tried refreshing the page and leaving it open for a couple hours but the page never loads. I tried making a new account but since I already used this email I can't use it again to make a new account and don't want to have to use a different email. Can someone please help me out? Thanks!
Most Helpful
Community Power User
Community Power User

Contact Telus. They should be able to either delete the partial,account so you can start again, or finalize the account information on your behalf.

 

NFtoBC
If you find a post useful, please give the author a "Like"