Wifi calling on Pixel 3XL won't turn on


I did it successfully on a previous P3XL on the same wireless account, and have the same struggles with my current P3XL, but this time I can't recall what steps exactly enables it on the phone.


When I turn the switch on for wifi calling, it brings me to the carrier pages (Telus) asking for verification and then 911 address information - I complete the entire process where the the last page (still Telus) says it has been turned on, and press the last button 'finish'. However, doing so takes me immediately back to the android wifi calling setting, and the toggle moves back to and stays off. Hitting the toggle on again just restarts the process.


I got it working once, what's wrong or what else should I try? There's no reason to suspect any differences between the previous phone and the same model I'm on now.


combing through the internet some discussion on the Rogers forum suggests this is related to devices not sold by the carrier - EVEN if they're the exact same hardware and software.

there's some extra layer of device registration for these features, represented by the 'IMS registration' status seen in phone information accessed by dialing *#*#4636#*#* ('unavailable' is my current status)

that is to say, If the phone wasn't sold by Telus, it wont be able to IMS register, and VoLTE and wifi calling won't work.

nothing on Telus' VoLTE or Wifi calling info pages say the device must be purchased from Telus.


Thus my next step is to call in to tech support and escalate until I find a rep who knows how to fix their end/my account so that the phone will get provisioned / registered on their network properly

Most Helpful



~30 mins on the phone with Telus tech support and explaining how provisioning the billing codes on my account for VoLTE/WiFi calling wasn't enough to enable these services on my phone and that I needed this supposed IMS registration, the rep went back and forth with me and his help desk a few times, we reset the phone twice, and eventually it worked and showed in the phone information menu (*#*#4636#*#*)


IMS registration status: available, VoLTE: available

WiFi calling - when I hit the toggle this time just moved to on and stayed on, didn't even have to do the setup process (presumably because it had been done several times before).

VoLTE - verified by making a call and phone stayed on LTE, did not drop to "H"SPA as it had been doing before.

verified wifi calling by putting phone into airplane mode, enabling wifi and the network in the notification shade said "Telus Wifi Calling"


The guess is non-carrier (Telus in this case) purchased phones are not whitelisted or in the system (their IMEI?) to automatically get IMS registered without tech support assistance.

I think in every 3rd party (Google in this case) purchase phone, the user WILL need to call in to tech support and speak to an agent familiar with the issue or is encouraged to really dig into the things they need to do on their end to get it working.

I also wonder if the device model has to be an approved one by Telus. e.g. can previous Pixels which have not been officially listed by Telus get this working if they support the features? Will only device models Telus has sold themselves work? I don't have answers to these questions and other users will have to try. I'd recommend obscuring what your phone model is or telling Telus it's one of the supported devices to get an honest attempt from them at getting working rather than just repeating a script that it's not supported. We want the real answer whether it can be done or not.

bonus round - Telus does not have eSIM beyond Apple watch at this time, but is working on it for other devices for future support (Pixel 3 supports it)

Telus does not have RCS/Chat (enhanced/advanced messaging) at this point, but is working on it for future availability


Also discovered sometime in the last few years is that Telus permits MMS usage whilst still maintaining a data block on your account, so you can be free to receive (and send if you have a package) picture and video messages, and not worry about pay-per-use data if you dont have a package for that. (it used to be that a data block blocked MMS too, it was all or nothing)

I'm disappointed this information was so hard to find on the net and wasn't provided by any of the providers themselves. There should be information on Telus' VoLTE and WiFi calling pages, for example that explicitly state users with 3rd party purchased devices will need to call in to tech support to get their device activated. I'm sad for mainstream users that A. dont know about these features existing B. don't know they need to be added to their account for billing purposes C don't know they're not actually working at that point and that they D need to call in and work with a tech to get them actually functional

I hope these posts help others who come after me who had the same questions and issues I did.

Community Power User
Community Power User


Thanks for sharing the solution you found. Hopefully Telus will add the asterisk for the need to register non-Telus phones.

If you find a post useful, please give the author a "Like"

I have a pixel 3xl from telus and I have been talking with Telus support for 4 days and they still cannot get my phone to work on wifi calling 


Thanks for the information. What I was looking for!


I have a Pixel 4 that I have just ordered off of the Google Store (as Telus doesn't offer the 128GB version). I am having similar issues.


Here are the statuses I get:


IMS Registration: Registered

Voice over LTE: Available

Voice over Wi-Fi: Unavailable

Video Calling: Unavailable

UT Interface: Available


in the Phone Info details, it shows Wi-Fi Calling provisionned as enabled (and locked gray). When I try to enable Wi-Fi calling from the android settings menu, it shows a loading page that never stops loading.


I've tried calling a few reps and they are convinced it cannot work due to it not being a Telus device. I've even referred to this thread.


Has anyone made it work with a Pixel 4 from the google store?

Community Power User
Community Power User

Might the link offered by @BarrieBob in this discussion be the solution?

If you find a post useful, please give the author a "Like"

BarrieBob's solution worked for both my Pixel 3a and my wife's, this was after 3 calls with Telus support, online chat with Google, a factory reset and a Telus support recommendation to take the phones back and reselect. 


If I had seen the link first I would have saved a lot of time and frustration.




thanks @kd225  , this was an instant fix for me, worked as soon as i filled out the info on the website provided


Good luck with tech support at Telus. 4 days and still unable to connect xl3 to wifi calling


Hi -- I had to jump through hoops to get a Telus purchased Pixel 3XL wifi calling enabled -- an hour or so on the phone with an agent who had to get back office support for some registration process.  Then I tried on Chat to get our second newly Google purchased Pixel 3XL to the same wifi calling state -- big mistake, agent didn't have a clue kept telling me that wifi calling could only be enabled if the device was being transferred from Rogers or Bell (seems nonsensical).  Finally gave up on the chat session -- back to the phone I guess and hope to get to someone who actually knows something.