TELUS does not support VOLTE for unlocked Note 8 - That is very bad

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Trident
Connector
Thanks Bill. I will be making a call into Telus tech support again. I will also open a ticket with CRTC to speed things up.
BillTelusCust
Ambassador

Good luck.

 

I had Rogers break something on my Wi-Fi calling once, they had to escalate it and it took quite some time to get fixed.  Although I have not had any issues with Telus, I suspect there are a few complications on the carriers' end that can get out of sorts.

 

I hope you are able to get this fixed, it must be very frustrating.

NegativeGM
Neighbour

Did you do any security updates?

 

every time i do these I have to call in and get them to fix it. Everytime i do a security update it some how blocks VOLTE. I also get told that it should work because it is installed. I tell them to read the notes on my account. This usually involves getting the original agent that did this to call me back. 

 

He did tell me that they are not suppose to be doing this. The Volte is only for Telus devices with "special firmware". I told him that this is false. All Note 8 (N950W) have the same build number, regardless  if it is bought from Samsung or purchased from telus.  

https://www.sammobile.com/firmwares/galaxy-note8/SM-N950W/

 

i have a Note 8 bought from Samsung Canada as well as a Note 8 bought from Samsung US (Flashed with a Canadian ROM). Neither phone would get VOLTE without calling in. 

 

So I did get it working, but it all depends on the agent you get and their amount of knowledge in fixing your VOLTE profile. 

 

NegativeGM
Neighbour

I have a Note 8 purchases in the US. They did get it working just fine. The phone was flashed with a Canadian Note 8 ROM so i could get the proper CSC codes.

 

The customer agent i got was awesome. What that link proves that you posted is how greedy telus and the others are. 

 

 

Trident
Connector
Thank you Negative GM, will be calling Telus now.
NegativeGM
Neighbour

if yours worked before and it is not now, then don't take no for an answer.

 

i could see if someone was trying an overseas phone that is just not set up for VOLTE. 

 

You are a paying customer and it's not right that you have to buy their sponsored hardware (That is identical in Hardware and software regards to one that is bought from Samsung) to get all the features you are paying for each month anyway. 

 

Just greed nothing more!

 

 

Most Helpful
Trident
Connector
Success! As I have suspected, the issue was with my profile on the backend. My profile has been fixed by Telus tech support. I got an amazing rep, very knowledgeable and who actually knew what he was doing. Here is part from his email that may assist other users here. P.S. I have a corp EPP account. P.S.S. as long as you have Telus software, you will have VoLTE and HD calling. The phone doesn't have to be purchased from Telus. The agent did the switch on his Note 8 to Telus CSC from Videotron device and was able to get his VoLTE and HD calling working thus confirming that as long as you have Telus software, you will have VoLTE and HD calling. Thank you everyone for you input and help on this topic.

----------------
"This is what we've gathered so far.

- VOLTE/VOWIFI codes were added to non-corporate accounts with a script and are not meant to be removed.

- Removing the feature may result in broken functionality

- We noticed that your profile was incomplete since the last time that the code was readded

- Tier II readded the feature properly. Please follow these steps to test:

1) Powercycle phone OFF and ON
2) deactivate voLTE
3) make call
4) activate voLTE
5) make call
"
BillTelusCust
Ambassador

Glad  you got it resolved, what you are explaining makes a lot more sense.  Hopefully you will not have this problem going forward.

NegativeGM
Neighbour
Trident;
When you shut off VOLTE and make a call does your phone still show your IMS as being registered?
I will try next time what you suggested, before calling them to fix my profile.
Glad you got it working. Hopefully VOWIFI will hopefully show up soon.
Trident
Connector
NegativGM,
When I switch VoLTE to off, IMS shows as Unregistered. When I switch it to on and place a call it shows as Registered.
Apparently, VoWiFi might be available with Oreo update. Fingers crossed.
Will123
Resident

Hi, not sure how long since this was last posted. I tried the same commands and got the following :

 

USSD Code running

Connection problem or invalid MMI code

 

Hope this means something to somebody and would appreciate any advice.