Caller ID Not Showing

Reply
Vanbot71
Resident
Many people tell me that an incoming call from me only says “Aldergrove” and my number. My number is indeed an Aldergrove number, moved over from FIDO years ago. How can I fix this so my name is shown on peoples’ caller ID’s on an outgoing call? Thanks, even some of my friends think I’m a telemarketer calling sometimes.
Community Power User
Community Power User

If I recall, Telus only recently started their Call Display +. Do you know if recipients of your previous calls (who did not have your contact info already) were seeing your number? It seems strange that friends who presumably have your number in their contacts list, are not seeing your name.

 

 

 

NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
Dogger596
Connector

I have asked for the same thing. Please see my post in the link below:

 

The more people that "like" the post, the more likely that Telus is to implement.

 

https://forum.telus.com/t5/Ideas/Outbound-Caller-Id-is-Needed/idi-p/87294

Sebastian342
Resident

To fix it I have so far tried few options.
1. Cleared contact, messages cache then restart phone, didn't work.
2. Clear phone cache then re-boot, didn't work.
3. Changed one of the contact number to start with country code, it worked.
My question is, is there any other way to fix this issue rather than changing all the contacts to start with country code?

Community Power User
Community Power User

Hmmmmm... interesting discovery! Including country code ensures the number is truly unique.

 

Wouldn’t all your contacts EXCEPT local ones already have the country code, thus lessening the number you have to change?

NFtoBC
If you find a post useful, please give the author a "Like"