Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to connect my Nexus 6P to #TELUSDirect

Just Moved In
My Nexus came without the ability to automatically connect to the #TELUSDirect network, but I managed to add it manually using instructions from the forum here. It worked well for about a month, but it is now telling me that there is an authentication error. I've tried to forget & reconnect to it several times, but I keep getting the same error. Any help would be appreciated! Thanks!

CPU Alum
CPU Alum

To clarify.... does your phone have a Telus SIM card plugged into it?


Community Power User
Community Power User

It isn't just the SIM card that controls the access. It's like a custom setting that goes in at an OS level. I had a nice Android phone I brought to Telus unlocked from elsewhere. It would see the #TelusDirect network but could never connect even with the Telus SIM card present and full access to everything else. Tech support had no idea how to fix it. Both the iPhone and S6, which I got from Telus, connected instantly with no issues.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂