Marshmallow update causes Bluetooth and WiFi problems

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

YLWGuy
Resident

I recently updated my LG G3 phone to Android 6.0.0.  My phone was working fine before this update.  I have two new problems after the update:

 

1. After answering a phone call with my Bluetooth headset the Bluetooth connection is dropped.  I have to reconnect the Bluetooth again in order to use my headset.  Apparently, this has been reported with other carriers and phones after updating to 6.0.0

 

2. Before the update I was able to Auto-Connect to a public WiFi.  After connecting to the public WiFi the login page would appear and I would accept.  I would have a working WiFi connection.  Now that I've done the 6.0.0 update I no longer get the Auto-Connect to the public WiFi.  When I go to WiFi networks to see what is available I can see my public WiFi network but it now has a message that says "Internet unavailable.  Cannot auto-connect".  If I click on the public WiFi it will connect, however, the login page does not automatically pop up like it used to with android 5.0.

 

Any suggestions on how to fix this?  According to some google searches these issues may be fixed with 6.0.1. 


Accepted Solutions
Most Helpful
urielball
Neighbour

WIFI Solution: Turn off your router, wait for 15-20 seconds and turn it back on.
Take out the battery from your LG G3, put it back in and turn your phone on.
Navigate to Settings > Wi-Fi > long press on your Wi-Fi network and then tap Forget Network. Then set up the connection again.
Check if the Battery Saver is on. If so, turn it off.
If the Bluetooth on your phone is on, turn it off as it may interfere with Wi-Fi connection sometimes.
In the Wi-fi screen you will see menu button at the top right. Tap the button and access Advanced Wifi. Try to change the settings here.If you see the option to connect 5 GHz instead of 2.4 GHz, try it out.
Sometimes, crowded channels cause the LG G3 Wi-Fi not connecting issue. You can install WiFi Analyzer app that shows the channels around you and helps you find the less crowded ones.
Verify with your router manufacturer to ensure that you have the latest firmware for the router.

Bluetooth Solution: Tun on the LG G4. Go to home screen and select the app icon.Then select on the settings icon.Browse for the Application Manager.Display All Tabs by swiping either right or left. Select on Bluetooth.Select to stop it forcefully.Now clear the cache .Select clear the Bluetooth data. Select Ok. Finally restart the LG G3

 For more more information visit LG G3 Manual. 

View solution in original post


All Replies
MortTheMuffin
Resident

Both myself and a friend from work have problems with our LG G3 phones for bluetooth, audio is choppy and unusable on our headsets basically making the phone unusable as we both use them for work

 

Tried contacting LG support, they wanted me to send the device in for repair even though I told them there are others with the same problem

 

At this point, looking into a method of rolling back to an earlier update if that's even possible

Most Helpful
urielball
Neighbour

WIFI Solution: Turn off your router, wait for 15-20 seconds and turn it back on.
Take out the battery from your LG G3, put it back in and turn your phone on.
Navigate to Settings > Wi-Fi > long press on your Wi-Fi network and then tap Forget Network. Then set up the connection again.
Check if the Battery Saver is on. If so, turn it off.
If the Bluetooth on your phone is on, turn it off as it may interfere with Wi-Fi connection sometimes.
In the Wi-fi screen you will see menu button at the top right. Tap the button and access Advanced Wifi. Try to change the settings here.If you see the option to connect 5 GHz instead of 2.4 GHz, try it out.
Sometimes, crowded channels cause the LG G3 Wi-Fi not connecting issue. You can install WiFi Analyzer app that shows the channels around you and helps you find the less crowded ones.
Verify with your router manufacturer to ensure that you have the latest firmware for the router.

Bluetooth Solution: Tun on the LG G4. Go to home screen and select the app icon.Then select on the settings icon.Browse for the Application Manager.Display All Tabs by swiping either right or left. Select on Bluetooth.Select to stop it forcefully.Now clear the cache .Select clear the Bluetooth data. Select Ok. Finally restart the LG G3

 For more more information visit LG G3 Manual. 

View solution in original post