Cannot Send/Receive Picture Messages - Bold 9900

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Neighbour

Plan: Voice Plan (No Data)

Device: Factory unlocked BB Bold 9900

 

My wife cannot send nor receive picture messages, she has unlimited txt msgs on her plan.  I've confirmed with Telus that data block has been removed.  I tried sending pictures between our phones with both data on and off on her phone.  Not sure why she's not receiving picture messages (MMS).  Other txt msgs seem to work fine.


Accepted Solutions
Highlighted
Most Helpful
Advocate

Try resetting the phone by taking out the battery and SIM card and then trying again.

 

Call customer service/tech support and see if there's a provisioning code missing from your account to enable the services.

 

The other thing it could be is...

 

Due to the fact that you have a voice only plan, legacy BBs, which are devices like the 9790, 9360, 9900, 9320 etc. running BB 7 OS or older, require a data add-on for picture messages to work. However, the problem here is that pay-per-use data is also not available on legacy BBs either, so you're stuck between a rock and a hard place.

 

Call client care and see if there's a workaround they can do for you.

View solution in original post


All Replies
Highlighted
Advocate

Hmm. Make sure data services are enabled, for one.

 

Since APNs can't be edited manually on a 9900 (as far as I know) you may need to register the phone for data use. Try this:

 

Options > Device > Advanced System Settings > Host Routing Table. Hit Menu and select Register Now. You should receive a registration message saying the device is now on the network. Enable data and try picture messages again.

Highlighted
Neighbour
Thanks Jonathan, I tried this and it says registration message sent however it still shows no entries and doesn't seem to do anything.
Highlighted
Most Helpful
Advocate

Try resetting the phone by taking out the battery and SIM card and then trying again.

 

Call customer service/tech support and see if there's a provisioning code missing from your account to enable the services.

 

The other thing it could be is...

 

Due to the fact that you have a voice only plan, legacy BBs, which are devices like the 9790, 9360, 9900, 9320 etc. running BB 7 OS or older, require a data add-on for picture messages to work. However, the problem here is that pay-per-use data is also not available on legacy BBs either, so you're stuck between a rock and a hard place.

 

Call client care and see if there's a workaround they can do for you.

View solution in original post