Unable to access my webmail

Reply
alkirkley
Neighbour

For the last week I have been trying to look at my emails via telus webmail but after entering my user name and password all I get is a "Loading" message even if I wait 15 minutes. I also can not access the "telus.com" webpage. I am outside Canada so I can not phone.

Highlighted
Most Helpful
Community Power User
Community Power User

Sounds like you are using Microsoft Edge. Edge is broken and does exactly what you see when trying to log in to webmail. Try a different browser.

dgregoroff
Friendly Neighbour

Try doing a screen refresh. Might work. I've had no luck trying to access my telus mobility account. Not sure what is going on with telus. 
For what they charge one would expect more.

Community Power User
Community Power User

@dgregoroff ,

   How are you trying to access My Telus, through the web, or the App?  I’ve had no trouble with either, and am curious as to the errors you see?

 

NFtoBC
If you find a post useful, please give the author a "Like"
dgregoroff
Friendly Neighbour

If I use Team Viewer and connect to my computer in Canada I can get to the Telus Mobility portal. I can enter my credentials and get access to my account information. Great! If I try to access the portal from S. Korea I get the site is unreachable. Telus is the only site that I’ve gone to that is unreachable.

Sent from Mail for Windows 10

Community Power User
Community Power User

I expect if you use a Canadian VPN, you’d also have no problems. I’d be guessing, but I expect it is specifically being blocked because you are outside Canada, or North America.

 

NFtoBC
If you find a post useful, please give the author a "Like"
dgregoroff
Friendly Neighbour

Worked fine when I was here last year.

David

Sent from Mail for Windows 10

alkirkley
Neighbour

I am trying via the internet. I did not know there was an app. I will try that.

alkirkley
Neighbour

Sorry I do not think that is the problem as I have been using it for a month before this problem started.

Community Power User
Community Power User

As mentioned in the other discussions about users outside Canada having connection issues, use a VPN. That has resolved the issues for others that weren't using Microsoft Edge. The issues with Edge started about a week ago for most users.

alkirkley
Neighbour

Thanks for the help. Even though Microsoft Edge had worked for a month changing to Firefox fixed the problem


@Nighthawk wrote:

Sounds like you are using Microsoft Edge. Edge is broken and does exactly what you see when trying to log in to webmail. Try a different browser.


 

dgregoroff
Friendly Neighbour

I’ve just tried Microsoft Edge to log in and that’s not working either.

David

Sent from Mail for Windows 10

dgregoroff
Friendly Neighbour

I’ve tried Chrome, Internet Explore and Microsoft Edge. I don’t know why Telus would block international connections. The only other thing I can think of is that an AVG antivirus update has screwed something up.

David

Sent from Mail for Windows 10

Community Power User
Community Power User

I'd be extremely suprised if it was Telus blocking access to their website. Doesn't make sense for them to do that. When travelling internationally you're at the whim of the ISPs over there. If they don't want to allow connections to certiain things, that's their decision. VPN will allow you to bypass many of those restrictions, assuming you're not using the ISP DNS over there. There are a few places I found while traveling where they block VPNs also. That includes a couple hotels.

dgregoroff
Friendly Neighbour

Well, low and behold! One day later and one Windows 10 update and I can connect again to Telus Mobility log on. It was either Windows 10 or Telus or both. I suspect it was Windows 10. I wish Microsoft would get things straight before they install updates.

David

Sent from Mail for Windows 10

ImAlfrd
Resident

Yeah, I too had the same problem with the edge.

dgregoroff
Friendly Neighbour

I tried 3 different browsers and someone else’s computer and all were the same. Today it all started working again. I think it was just Windows 10

David

Sent from Mail for Windows 10

thunderbird
Connector

there is a outage for this, currently no ETR

Community Power User
Community Power User

It's not an outage when it's isolated to one browser. Webmail works fine in Chrome and Firefox.

thunderbird
Connector

Hi yes the workaround is with chrome or firefox, the issue specific is with Edge, No ETR