Telus Assistant fails to register on Google Home

Reply
WalterThompsonSunday
Neighbour

I attempted to link the Telus assistant to my Google home but it keeps failing. I believe it's because I accidentally used the wrong Telus account, however I cannot find a way to change the login information. Before I completely delete my Google Home and recreate everything from scratch, anyone know how to change the account information?

WalterThompsonSunday
Neighbour

Issue resolved. I logged onto my Google account. I had looked under 3rd party links previously and found nothing. I deleted my Home, re-created and nothing. I went back to my Google account and under Linked accounts, I found the Telus Home Assistant link. I deleted it, then finally was able to add the Telus Home Assistant successfully.

TELUS Employee
TELUS Employee

@WalterThompsonSunday Thanks for the information on the issues you had the first time you attempted to link your account, and happy to hear that after troubleshooting you were successful! Let me know if there are any other issues you encounter when trying to use the skill. 

Kevin123
Resident
I’m having exactly the same problem. How did you find the section for linked accounts to delete the wrong TELUS account I linked?
WalterThompsonSunday
Neighbour
Go to Google .com and log into your account.
Click on your profile icon to open your account settings.
On the left select Security.
Scroll to the bottom of the page and select Linked accounts.
Find the Telus Assistant and unlink it.
Took me for ever the first time, seems so simple once you know where to look!
Rory51
Resident

What steps are you taking?  I had some difficulty setting it up at first, as it wasn't properly loading on Google Assistant. I also believe you need to be on Fibre.

Highlighted
Community Power User
Community Power User
Can be on copper or fibre..

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
ADC
Connector

I'm also having an issue with linking, but I think the problem is it does not see the optik boxes. When I link via Google Home, and then sign in and allow Telus/Google to integrate, it just goes back to the setup screen and my optik boxes do not show up. I can unlink Telus (not via the GH App, but via google.com as described below), so it is linking. I had the same problem with Telus Assistant BETA, but the moment I signed in using my Optik account (instead of My Telus), everything worked. Now that Telus Assistant has officially launched, how can you sign in via your Optik Credentials?