Having difficulty with installation of a switch.

Reply
Zman2k2
Ambassador

Hey all, hoping someone can help me.

 

I decided to go wired on my entertainment stand, instead of the wireless I was using before.  So in that vain, I went out and bought a D-Link DGS-1005G switch.  I have my DVR, blu-ray player and XBox One on one line.  The problem is, while watching TV, it suddenly freezes, pixelated, no audio or other things.  It gets worse if you're recording on one channel and watching another.

 

I thought all unmanaged switches were the same, so I'm not sure what I'm doing wrong.

Most Helpful
Community Power User
Community Power User

What happens if you try various combinations of devices connected to the switch? I'm wondering if the Blu-Ray player is a slower device and slowing the network at the switch.

 

NFtoBC
If you find a post useful, please give the author a "Like"
Zman2k2
Ambassador

I thought of that, and just connected the DVR and the ethernet connected to the 3200M.  Still the same problem.

Community Power User
Community Power User
Is your optik tv receiver running through the switch?

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Zman2k2
Ambassador
Yes it is. I have the three listed devices in my first post connected to the switch.
Zman2k2
Ambassador
I think it might be the wrong type of switch. It says it does media, but mentions nothing of igmp snooping. And if I'm running the DVR through it, I'd need that, right?
Zman2k2
Ambassador

That is exactly what it is.  I start with the switch and just the DVR.  Then, a few minutes later, add the XBox One.  Then, a few minutes later, add the blu-ray player, and within 20 seconds, the freezing and pixelation start.  Any way to fix this?

Community Power User
Community Power User

You MIGHT have success with using a router instead of the switch, but that adds a. bunch of other complications. Can you connect the Blu-ray player only when needed, and the DVR is not in use, or connect it directly to the Actiontec router bypassing the switch?

 

NFtoBC
If you find a post useful, please give the author a "Like"
Zman2k2
Ambassador

Actually, I'm trying to simplify my wiring behind the entertainment unit.  You know how it becomes a rat's nest of wires.  Hence, the switch.  I suppose I could rerun the cable I took out, but it's about 100ft from the Actiontec. Smiley Happy  I might just rerun the ethernet cable for the DVR, and run everything else off the switch.  Just have to decide, plug and unplug, or new cable.

 

Thanks for narrowing it down for me though.  I appreciate it.

Community Power User
Community Power User
You will need a router or switch that supports IGMP (multicast). Hence it freezing, pixelating etc every 10 seconds or so.

I understand if I read correctly you have your optik receiver connected to that dlink switch (doesn’t have multicast)

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Community Power User
Community Power User

For me I have a gigabit switch behind my PVR and I've also got a PC, BluRay Player and Roku connected to it with no issues. My old Linksys switch developed a very similar issue to what you're experiencing except that I got pixelation and stuttering when 2 video streams were in use, like recording one thing and trying to watch live TV.  So it's going to be extremely specific as to which switch you can use. The one I have now is a ZyXel GS105SV2 gigabit switch, and it has been really solid since I got it a few years ago. They are a little harder to find but for me it's been great.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Highlighted
rc
Ambassador

If the problem appears when the only device connected to the switch us the pvr then the switch or cable connection is suspect.

 

Looking at the interface statistics on telus router could provide some clues to the cause. A lot of retransmission and errors would indicated a cable problem.

PL
Coach

Hi

No offense to D-link but I've had issues in the past. I only use Netgear now. 1GB switches. Work flawlessly.

Basic switch.

Good luck!