Has Telus fixed the glitches in the Technicolor 4K HER boxes?

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Zman2k2
Ambassador

Hey all,

 

Backstory here is, about 6 months ago, I upgraded to the 4K Technicolor boxes.  Problems ensued from the beginning.  The boxes, all 3, within 5 minutes of each other would reinitialize.  I have a Sharp TV, and the Telus remote would turn the TV on with the box, but only power off the box, leaving the TV on.  A subsequent press would reverse what was powered on.  Could never get them to sync up, and I tried every remote code, called tech support, nothing.

 

Now I'm thinking of jumping back on the 4K bandwagon, but I'm leary of the boxes.  Anyone else have any horror stories?

Zman2k2
Ambassador

Can't find the edit button,

 

should remark that the boxes resetting was around 15-20 a day, every day.

Most Helpful
Community Power User
Community Power User
I’ve heard a few people having issues with the technicolor receivers. The Arris 4K receivers don’t seem to replicate the issues of the technicolor ones.

Can always request the Arris ones as they’re the primary stock.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Zman2k2
Ambassador

Really?!  I had no idea.  I'll  definitely be asking for them, then.  Thanks.

Sparky33
Resident
With have the same problem. Will contact TELUS to replace the box.