Showing results for 
Show  only  | Search instead for 
Did you mean: 

slow and unreliable downloads from Apple Content Distribution Network (App store)


I have had Telus 15Mbit ADSL for many years and just recently have come across an issue accessing content on Apple's Content Distribution Network (CDN) that is negatively impacting our house – and likely those of other customers as well. 


For the past several weeks we have been having problems in our home downloading content from Apple's CDN, most notably IOS 8.0 (1GB per device) and most recently the MAC OS Yosemite upgrade (5GB).   Downloads from Apple's CDN are extremely slow (estimate of 5+ days to download MAC OS Yosemite update, and 2+ hours for 69MB IOS 8.1 update), and downloads often fail before completing.    Downloads from other content providers we use have been working reliably with throughput close to our connection speed, so this problem appears to affect only some content providers, and maybe only Apple's CDN. 


I have verified our internet connection both wirelessly and wired using which produced results of 14+Mbit/sec download and +.75Mbit/sec uploads wired and slightly less wirelessly.   The problem with extremely slow and failed downloads occurs on both wired and wireless devices.  


I spent some time troubleshooting in the last couple of days.   Our regular router has been assigned IP address 50.92.132.X/ with default gateway and DNS Servers and by Telus through DHCP.   During my testing I observed the Apple App store establishes a connection with or for the download.


Yesterday, out of desperation, I connected a borrowed router (same make and model), which was assigned IP address 75.156.108.X/ with default gateway and DNS Servers and by Telus through DHCP.   I tested the connection using and got nearly identical results as with my normal router of 14+Mbit/sec download and +.75Mbit/sec upload wired.    I then tried to access the MAC OS update from the Apple App store and found that it downloaded all 5+GB in less than an hour!  For what it is worth, the network stats I gathered showed the download was from the same host as previous attempts – which to me indicates some kind of bottleneck related to routing to the network my assigned IP address is on.


Today, in an effort to understand the source of the issue, I switched back to my regular router, which was assigned an IP on the 50.92.132.X network and the problems accessing content on Apple's CDN returned immediately.   I then configured my regular router to use the MAC address of the borrowed router that I connected last night, and just like the borrowed router, my regular router was assigned IP address  75.156.111.X/ with default gateway and DNS Servers and   With this change MAC address and in assigned IP address - nothing else, content on Apple's CDN such as the MAC OS update could be accessed and downloaded at expected speeds using my regular router.


My conclusion:   For some reason, being assigned an IP address on 50.92.132.X/ network is resulting in extremely poor throughput and unreliable transfers accessing content from Apple's Content Distribution Network and possibly other content providers.   As long as I have a MAC address that continues to get an IP address on the 50.92.132.X network, I can reproduce the problem very easily.


Does anyone know how Telus assigns IP addresses these days?   I know many years ago you had to register devices with Telus to get internet routable IP addresses, but that URL does not seem to be accessible anymore and I seem to be able to get an internet routable IP address to devices not registered with Telus, so I am guessing the registration process (at least the manual one) has been eliminated.


Has anyone else experienced anything similar with Apple or other content providers?


Community Manager
Community Manager

Dru from TELUS here.


Thank you all for bringing this to our attention! 


Your input was invaluable in helping us identify a challenge at a connection point between our networks. We are working closely with Apple to increase peering capacity and everything should be resolved soon.


On behalf of the TELUS Neighbourhood team, thank you so much for your patience on this matter and sorry about the inconvenience.

View solution in original post


I can confirm that switching my DNS to the UK address ( has fixed the problem for me. Nothing else worked. I haven't experienced slow download speed like this since having dial-up 15 years ago!

I can confirm that using this UK DNS address fixed things here in PoCo also.

I can also confirm that switching to the suggested UK DNS server avoids the Telus/Apple bottleneck. Download time went from 5 days to 5 hours and its finally making progress.


I chatted with Telus Support yesterday to no avail. They claimed that they were aware of the issue but suggested that it was on Apple's end. But at least they are aware of the unhappy customers.

Considering it's only two very specific files and other downloads from the same server are downloading fine, that would make it seem more of an Apple issue. 

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I suspect it's not an Apple issue at all.  It's fairly apparent that Apple's "big" downloads (full MacOS/iOS updates) are sitting on different ACD servers.  (Not withstanding that, I had the same bottleneck issue with a measly 66MB Apple-sanctioned Java update yesterday.)

Here in British Columbia, changing from a TELUS-owned DNS server to a non-TELUS one  -- but still using TELUS DSL -- fixed the issue.  I was able to quickly update to OSX10.10 and iOS8.1 whereas previously it'd be days of waiting.

This leads me to believe its either a routing issue or a throttling issue with intermediate US carriers.  This was exemplified by a less-than-favorable traceroute I did to Apple's ADC servers using their DNS server. The stall I saw was well beyond TELUS' network.



By pointing your DNS to the UK address, you will be directed to download Yosemite or iOS 8.1 from the Apple CDN servers in the UK, instead of from the Apple servers in the US.  


My suspicion is that Telus has cached the downloads from the US Apple servers and that it is Telus edge servers that are to blame.

Just Moved In

My iOS 8.1 update said over 30hrs to download on both my mac and over the air on my phone. I went to my girlfriends house and the update took less then 15min on my phone. She is on shaw I am thinking it may be time for a change. I talked to telus and there answer was your downloading at the right speed.


I can also confirm that using a VPN has made the Yosemite oSX download to less then 1 hr. Substantially faster

Sorry to hear about your frustrating experience with Telus Customer Support. I try to avoid chatting with them unless its a last resort. The frontline agents are usually very friendly, sympathetic and only marginally knowledgeable. Its probably in the job description.


Apparently Telus has now fixed the bottleneck. I just started downloading Yosemite on a third Mac and the App Store app says less than 2 hours duration for the whole download. I am using the default Telus DNS this time and it seems to be working.


Wouldn't be nice if Telus paid attention to their own forums (here in particular) and firstly acknowledged the problem honestly and then let us know when it was fixed.

yes it seems telus has sorted it out.  i downloaded yosemite for a mac book pro this morning without changing any settings and it was 45''   

Community Power User
Community Power User

@RJD Thanks for sharing. I downloaded iPad update for SWMBO this evening in 11 minutes at speeds in excess of 3.5 MB/s, about what I expected to see with my current plan.


I'm pleased this is resolved.


If you find a post useful, please give the author a "Like"

Helpful Neighbour

Does anyone know what caused this problem?  I'm having a similar problem with App Store updates crawling with my Internet 50 plan. reports proper speeds, but updating apps for the last week or so has been insanely slow on both wired and wireless connections.  e.g. a 5 MB app update takes 5-10 minutes.


My downloads have been fine for months, but Apple downloads are running extremely slow again, as Frosty says.

I was updating some apps and it said that some were going to be 15 to 20 minutes each.  So, I switched on my VPN (to the UK), which bypasses Telus local servers and they were done within a minute!  So there's definitely a bottleneck, again, between Telus and Apple.

Helpful Neighbour

The silver lining that you're seeing the same issue is that I might have an easier time convincing tech support that the problem is real.  Hopefully more people chime in.

What VPN are you using?

I use a VPN service called StrongVPN. It costs US$50 per year and allows me to watch UK TV. Many people in Canada also use a service like this to expand their NetFlicks choices because the US NetFlicks has a lot more choice of what to watch.

Helpful Neighbour

Yes, I'm familiar with VPNs -- though not StrongVPN.  Can you use that at the router level or just at the device level?

I too have had apple update issues. I've tried changing DNS settings as
mentioned on some apple support discussions to no avail.
But reading this thread reminds me that I believe this happened in the past
(with Telus) and was not quickly resolved...


I use it at the device level.  This allows me to connect to it from my phone or computer, even if I'm not at home.

Helpful Neighbour

iPad, iPhone as well as OS X updates are affected for me here.

Helpful Neighbour

I've tried Google, Australian, UK, Chinese DNS to no change.

Just Moved In

I attempting to start updating iPhone and iPad apps on my WIndows 7 PC last night (for the first time in a long time), and I noticed these abysmal download speeds.  I gave up for the night and tried again today, with no different result.  A few days before I had updated to iTunes (64-bit).. not sure if that is causing the problem? (don't think so, but mentioning it)

I've also tried updating apps on my phone directly, over my home wifi network and it seems to have the same problem of slow downloads of the app updates.

I have the Telus Internet 25 plan.  I have no problems watching YouTube videos or loading pages on any other websites I have been using.

Let's go Telus... fix this issue please.

Helpful Neighbour

everyone having this problem should stop troubleshooting. it's between telus and apple. if you need to get 500mb of updates on your ios device, you can grab the tunnelbear app and sign up for a free account, and enable the usa vpn. tweet about it to get another free 500mb for a total of 1gb.