Showing results for 
Show  only  | Search instead for 
Did you mean: 

slow and unreliable downloads from Apple Content Distribution Network (App store)


I have had Telus 15Mbit ADSL for many years and just recently have come across an issue accessing content on Apple's Content Distribution Network (CDN) that is negatively impacting our house – and likely those of other customers as well. 


For the past several weeks we have been having problems in our home downloading content from Apple's CDN, most notably IOS 8.0 (1GB per device) and most recently the MAC OS Yosemite upgrade (5GB).   Downloads from Apple's CDN are extremely slow (estimate of 5+ days to download MAC OS Yosemite update, and 2+ hours for 69MB IOS 8.1 update), and downloads often fail before completing.    Downloads from other content providers we use have been working reliably with throughput close to our connection speed, so this problem appears to affect only some content providers, and maybe only Apple's CDN. 


I have verified our internet connection both wirelessly and wired using which produced results of 14+Mbit/sec download and +.75Mbit/sec uploads wired and slightly less wirelessly.   The problem with extremely slow and failed downloads occurs on both wired and wireless devices.  


I spent some time troubleshooting in the last couple of days.   Our regular router has been assigned IP address 50.92.132.X/ with default gateway and DNS Servers and by Telus through DHCP.   During my testing I observed the Apple App store establishes a connection with or for the download.


Yesterday, out of desperation, I connected a borrowed router (same make and model), which was assigned IP address 75.156.108.X/ with default gateway and DNS Servers and by Telus through DHCP.   I tested the connection using and got nearly identical results as with my normal router of 14+Mbit/sec download and +.75Mbit/sec upload wired.    I then tried to access the MAC OS update from the Apple App store and found that it downloaded all 5+GB in less than an hour!  For what it is worth, the network stats I gathered showed the download was from the same host as previous attempts – which to me indicates some kind of bottleneck related to routing to the network my assigned IP address is on.


Today, in an effort to understand the source of the issue, I switched back to my regular router, which was assigned an IP on the 50.92.132.X network and the problems accessing content on Apple's CDN returned immediately.   I then configured my regular router to use the MAC address of the borrowed router that I connected last night, and just like the borrowed router, my regular router was assigned IP address  75.156.111.X/ with default gateway and DNS Servers and   With this change MAC address and in assigned IP address - nothing else, content on Apple's CDN such as the MAC OS update could be accessed and downloaded at expected speeds using my regular router.


My conclusion:   For some reason, being assigned an IP address on 50.92.132.X/ network is resulting in extremely poor throughput and unreliable transfers accessing content from Apple's Content Distribution Network and possibly other content providers.   As long as I have a MAC address that continues to get an IP address on the 50.92.132.X network, I can reproduce the problem very easily.


Does anyone know how Telus assigns IP addresses these days?   I know many years ago you had to register devices with Telus to get internet routable IP addresses, but that URL does not seem to be accessible anymore and I seem to be able to get an internet routable IP address to devices not registered with Telus, so I am guessing the registration process (at least the manual one) has been eliminated.


Has anyone else experienced anything similar with Apple or other content providers?


Community Manager
Community Manager

Dru from TELUS here.


Thank you all for bringing this to our attention! 


Your input was invaluable in helping us identify a challenge at a connection point between our networks. We are working closely with Apple to increase peering capacity and everything should be resolved soon.


On behalf of the TELUS Neighbourhood team, thank you so much for your patience on this matter and sorry about the inconvenience.

View solution in original post



When you say 'router', you mean Telus Actiontec gateway?(non-bridged).


The Telus IP of 50.92.132.X, which may GEO Region report as being somewhere in Canada(as long as GEO routes are up to date at Apple) to the Seattle server, could result in a bad routing.

You'd need to do a trace route to see if Apple CDN sends you on a different route with each IP choice.


The modem(MAC) registration to the Telus network is an automated process. MAC expiration(unplugged from Telus network) will usually happens within minutes. Quite reliable.





I have a Siemens SE567 in bridge mode, so it is the MAC address of my Linksys WRT54GL router that is being used to obtain the 50.92.132.X IP address.   A second identical router with a different MAC address receives a 75.168.108.X address.   


I did try a traceroute with both routers and surprisingly it was very similar - except a couple specific 10.X routers (no reverse name) that were slightly different addresses I believe..



The Telus(hop past your router) 10.x.x.x network routers are on the 'converged edge network'.  Faster path to your destination.


Could be network routers for the 50.x.x.x range having problems.


Two found contacts for 'Telus network' support. They are about the only way to avoid all the 'I don't knows what you mean' from other support channels. Peering would be a good start.




Community Power User
Community Power User

@rjw wrote:



Has anyone else experienced anything similar with Apple or other content providers?

Yes, I am finding much the same, though I have not done the detail you have. I recently subscribed to Fibre 25/5. My discoveries:


iOS Apps download / update through iTunes as expected; about 5x the previous speed

Yosemite was promising an update time of 2 - days. the update finally gave an error and a retry from the purchases page gave a 30 minute download - corrupted, I believe because of the early data to which the final was appended. Deleted the file in Applications and retried - took about an hour to re-download a good copy. Finally installed last night.


Gave up on iOS 8.1 downloads. Getting 22 - 48 hour estimates depending on DNS servers. Get 22 hours with Telus DNS, and 40 with Google DNS or Open DNS. New bytes are added to the existing (corrupted?) file.


Downloads from other sites seem what I'd expect: Open Office, Youtube and SpeedTest give speeds as expected. I've tried SpeedTest to California, Texas and Florida with little loss in speed though a few long pings (113ms).


Modem address: 172.218.121.xx

Default gateway 172.218.120.x


Please share what you learn.


(I'm SO happy I'm not alone...)


If you find a post useful, please give the author a "Like"

Although not a fix for Telus speeds directly, the way I got around this issue was to use a VPN.


I too was getting an abysmally slow download speed of Yosemite and the latest iTunes (OS 8.1 on my phone was fine).  So when I found out that it had something to do with the Telus connection, I switched on my VPN that I have to the UK and the speed was much faster.  Yosemite downloaded in just over an hour.


So, if you have the ability to use a VPN to somewhere else, use this for downloading updates and it will work much faster.  I use a service called StrongVPN, but I think there are some VPN providers that have free trials.


I'm experiencing the same problem the past several days. I'm on the Telus 25Mbps plan. download speed from every other site is fine, but for some reason updates from Apple's Mac App Store this week are unbelievably slow. 


I have a Zyxel modem from Telus, in bridged mode, using my own router. My router has been assigned a different IP address than others have been reported here, in the 108.180.x.x range


updated a couple devices to iOS 8.1 on Monday, but attributed the slowness due to first-day-available server load.


later I tried updating one of my Macs to Yosemite - download crawled along at dial-up pace for more than a day. App Store was estimating 5 days to complete the 5GB update. After a day and a half of retries and waiting, less than 10% of the file had downloaded.


based on comments of this problem in Apple's discussion forums, I tried pointing to different DNS servers (which helped some people in similar situation, many of them also with Telus), but this didn't help in my case. I later connected via VPN and suddenly my download speed resumed to normal.


I'd be interested to hear why it seems Telus customers like us are experiencing problems with these Apple updates, and if there's any proper solution


I can concur that download speed from Apple over Telus are excruciatingly slow for the past week (25Kbps - 100Kbps)

on a Optic 25Mbps account.


I also tried to use different DNS settings, to no avail.  


However, when I used a VPN to dial in to a Seattle hub, my download speeds jumped up to more than 3.2 Mbps.


I suspect that Telus is either cacheing the Apple downloads and their edge servers are the problem,

or they are limiting the aggregate bandwidth for all connections to the Apple servers themselves.  

Community Power User
Community Power User

This morning I called Telus Tech Support and spoke to John, then transferred to Val in solutions. Was first told the problem was elsewhere, was with Apple etc. Countered with the discoveries here, including bypassing Telus network with VPN and use of MAC addresses from old Gateways. Also indicated that if due to Apple, there would be pandemonium on the internet, but it is quiet, and seems just a problem for SOME Telus users. Asked Val to create a ticket, as this would not be corrected over the phone, and invited him to stop by here and learn what the community has discovered, offer comment and address a solution.


If we don't see a post from Telus Solutions today outlining their discoveries, I expect I'll be calling again tomorrow.


A question for the group: is your Telus connection Wireline or Fibre? Mine is fibre - is this a commonality?


@captnkirk Your speeds are similar to mine - I am seeing 0 - 50 KB per second on Activity monitor. Throughput of about 1GB per DAY.


EDIT: It would be nice to receive comment from Telus on this issue. It has been fermenting a couple of days now, and has been viewed over 500 times. 




If you find a post useful, please give the author a "Like"

Community Power User
Community Power User

@abcd can you provide the link to the Apple Discussion boards you referenced your post?




If you find a post useful, please give the author a "Like"

Good Morning!


One of the Apple discussions is at:


And, for reference, I'm on a new 50/10 fibre connection. 


Modem IP Address:
Subnet Mask:
Default Gateway:
DNS Address #1:
DNS Address #2:



My service is copper - 15Mbit/1Mbit, and I am still using a Siemens SE567 modem.    I would love fiber - but it is not available in my area.   

Many thanks to those who offered advice... It proves the value of this forum for a non-techie like myself.


I managed to finally download (at my previous speed) and install iOS 8.1, using an AMERICAN VPN.    It would definitely seem the problem lies on the Canadian side of the border, which of course makes it Telus' problem. 

Even a cursory search of the web shows no major issues/compaints about Apple Servers (other than the usual first day of release)... also I had no problem downloading the original iOS 8.0 release...


It will be interesting what happens with the next Apple update downloads.

hi NFtoBC


KyleMW beat me to it - the discussion thread I hinted at earlier is the same he lists in his post above.


a couple other minor data points in my case:

I normally use OpenDNS DNS server. I tried using Google DNS as suggested in the Apple discussion, but that didn't help. the only workaround that let me download the update with reasonable speed was using a VPN with endpoint in the US. 

I'm on Telus 25Mbs plan, and AFAIK it's copper service(is there some way to tell for sure?).  Zyxel 1432 modem in bridged mode, my own Apple Airport Extreme router. if there are any other clues I can contribute to this discussion let me know

Community Power User
Community Power User

So I set up Unblock-us .com VPN just now (free 1 week trial) and download time to iOS 8.1 went from 21 hours to 21 minutes.


Since it seems ANY VPN addresses this issue, and I have seen no complaints from Shaw, Bell or Rogers customers on the Apple Discussion Boards I'm of the opinion that this issue is a Telus one not an Apple one. Note about 17/58 comments in the Apple support discussion mention Telus.


I'm quite disappointed with the dismissive response I received from John and Val this morning, as it seems there is little interest in addressing an issue clearly enunciated by the members here. Smiley Sad

If you find a post useful, please give the author a "Like"

Hi.  I too am having this issue (slow/incomplete downloads of Yosemite).

Guess I will try a VPN, but really that's not the solution. I should contact Telus support too.  Regardless... when folks are changing DNS server pointers, are you doing that at the computer level or in the settings of the modem (in my case an ActionTec V1000H)?



Disgruntled in Vancouver

Community Power User
Community Power User

@emcee2 wrote:

  Regardless... when folks are changing DNS server pointers, are you doing that at the computer level or in the settings of the modem (in my case an ActionTec V1000H)?



Disgruntled in Vancouver

I simply changed the DNS entries in my Gateway and let it reboot.


I hate to think how challenging this process would be for many of the folks I know (the same one who would have had 12:00 flashing on their VCR in the day). 

If you find a post useful, please give the author a "Like"

Exactly the same problem in PoCo here.  Normal speeds of 3MB/s have slowed to about 40KB/s when solely attempting to update Yosemite.  I have had to restart the download at least a dozen times, so its integrity is now suspect; I'm about 2.0GB into the 5GB download.


Needless to say, I gave up early on attempting an OS 8.1 update.


Running an ActionTech V1000H modem, which I've rebooted a few times.  Unfortunately, I don't have the luxury of a VPN setup.




My story from Prince George.

I am a telus optik customer.

The first day yosemite was released I downloaded with very quick results, less than an hour.

Next day i wanted to upgrade one of our other computers.  Not so good, same story as all the posts on this chain.  Waited days and finally gave up.  then I came across these posts and not being a tech person I just googled free vpn, came across cactus vpn, free for 24 hours.  simple set up and fantastic downloaded yosemite in about 40 mins.  

So I assume telus has a problem...


ps if you do get a good download then suggest making a usb installer copy first.

If you went to System Preferences > Network > Ethernet and entered the number into the DNS Server field there (might be under an Advanced Button/Tab), you could have saved yourself going the VPN route.  (Make a note of the current DNS number and revert to it later).


Also, I wouldn't recommend going the USB installer route.  I tried that once, thinking I'd at least alleviate one massive download in our household.  I used the installer on my wife's computer without any problem.  But, about a year later, her machine booted to a firmware screen with a warning about an illegitimate OS install.  The OS download/install must be signed by an AppleID via a proper Apple Store download/install.  Yup, it's a drag.

Community Power User
Community Power User



Some of the VPN options are as simple as changing the DNS settings in one's gateway, however, your suggestion to use a UK-based DNS server does remain a no-cost option into the future.


If you find a post useful, please give the author a "Like"