foscam webcams not working with Telus actiontec t1200h

Neighbour

foscam webcams not working with Telus actiontec t1200h

I just switched from Shaw to Telus for internet and tv.

 

I have 4 foscam ip webcams.  They worked fine on Shaw with my own Asus router.

 

But I can only get 1 of them working now with Telus's modem/router.

 

Each of the webcams have a static ip address and their own port #. 

 

I have set up the port forwarding in the Telus actiontec modem/router.

 

But on my internal network, only 1 of the cameras will stay connected or connect at all.

 

Has anyone else been successful with Telus optik internet and multiple webcams?

 

Thanks.

9 REPLIES 9
Advocate

Telus blocks some port numbers on dynamic IP accounts.  

tcp ports 21, 25, 80, 110, 443, 6667, 8080

tcp/udp 135-139, 445, 1433-1434


If your cameras use those ports it will not work remotely.  First step is to change all the port numbers on your cameras to avoid the blocked ports.


Second thing, you cannot test this from inside your own network.  The Actiontec routers do not support NAT hair-pinning.  It will NOT redirect a request from inside the LAN made to the WAN IP back to the LAN again.  Yes, it's maddening that this routing feature is missing yet works on every cheap disposable NAT router sold.  So if you are troubleshooting this without connecting to an external network you will fail 100% of the time trying to connect to your camera by using your ddns name or public IP address while connected to the home network.


Last, if you are using port 1 bridge mode on t1200/2200 (Not DMZ forwarding) means that if it failed for you then you are using one of the blocked ports or are not configuring your own router properly.  The bridge mode is entirely transparent to that device, it gets it's own IP and everything.


Yes I have it working, had to change ports to avoid blocking.  Had to change camera advanced settings to modify RTSP ports as they all defaulted to using the same UDP port 554 even if the web interface port is changed to be unique.  The webui port and the RTSP streaming port are often different and independently set for these cameras.  When a single camera works it usually means the cameras are successful at silently setting up UPNP port forwarding with the router but only a single camera at a time can grab that port.  You have to find where to change the streaming port number.  

Usually best to test with VLC direct to the RTSP streaming URL of the camera to verify the port works.  The webui is often shockingly bad on most cameras.  Most still require activex plugins with the native web pages for [censored] sake.  May be a challenge to find the correct setting.

eg for VLC streaming URL:

rtsp://admin@192.168.1.11:8088/videoMain


Camera may call this the media port.

default is usually 554

Suggest something like 10554,10555,10556,10557 etc unique to each different camera


Resident

I have the same issue.  It is not worked around by bridge mode.  Either there is a bug in the 1200 or there is an additional firewall that can be access by the Telus client.


After many hours on the phone I've been told by some reps that the 1200 does not allow port forwarding and that there is a sim card that can resolve the issue.  A strange answer since there are no inputs on the 1200 other a usb port.  And it was not clear what this sim card does.  Does it update the firmware?  Does it allow for access to a super secret admin interface with a more front facing firewall?  


Oh well, I've given up on Telus and am cancelling my service.

Neighbour

 
Neighbour

I have set up a different port for each camera.

I previously had them set up on a Cisco/Linksys router and I was able to access them via their individual web addresses.

Community Power User

Do you have multiple cameras all trying to utilize the same port# (not to be confused with the 4 numbered ports) on the gateway? If each camera has it's own internal IP, assuming you have the routing set up correctly for each individual port / camera, you'll likely want to have different external port numbers for each so they don't conflict. That's also wildly assuming they'll work like that without the gateway being bridged.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂
Neighbour

Telus Actiontec T1200H 

Foscam FI8910W Cameras X 4


I have a slightly different problem, but may be related.  I have 4 Foscam IP cameras with DDNS built in.  They all work locally, i.e. if I use the IP and port #, but I cannot access them on the web.  In the camera settings and it says that the DDNS is all good.


I have set aside an IP for each camera as well as a port for each IP.


I don't have an option to use a different router and port bridge.


Thoughts?

Rockstar

A quick fix.

Use your own router for the webcams/internet and use the Actiontec for just TV.

 

Port1 bridging, under port bridging in the Actiontec T1200/T2200H gui.

Your Asus router will then get its own internet routable IP address.

 

 

 

 

ah yes.  I tried the port1 bridge mode.  But I got confused on setting it up.

 

I connected the Actiontech from lan1 to the WAN port on my Asus router.

 

The Actiontec has 192.168.1.254 as the gateway and 255.255.252.0 as the subnet.  I set the dhcp ip range to be different from the dchp range of the Asus router.  I also turned off the wifi on the Actiontec and removed all port forwarding.

 

My Asus router has 192.168.1.1 as the gateway and 255.255.255.0 as the subnet.

 

I set the foscam webcams to use the Asus router gateway and subnet.  I setup the port forwarding on the Asus router.  I also setup the static ips on the Asus router and foscam webcams (just like I had on my Shaw setup).

 

But I still had the same problem of only 1 webcam connecting.  The other ones try and then just disconnect.

 

Is there anything else I need to do for using Port1 bridging to keep the routers separate?

 

Thanks.

 

 

 

 

The port1 bridge bypasses the routing capabilities in the Actiontec, making a direct path to the WAN(incoming service from Telus) and its own IP address, so no router conflicts.

 

Should be set port1 bridge to active and plug in. Just for sure, reboot the Actiontec. Then you can check to see that both have a separate IP address. https://encrypted.google.com/#q=check+ip

 

 

page 53

http://static.telus.com/common/cms/files/internet/telus_t2200h_user_manual.pdf

Advanced Setup
Port Bridging
Click
Port Bridging
from any Advanced Configuration screen to generate the
Port1 Bridge screen. This screen allows you to enable port bridging. Click in the
Enable radio button to activate, then click
Apply