cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

actiontec t1200

rayrayjj
Rockstar
Why doesn't actiontec still sell the t1200 on there website? Is there a reason?
1 ACCEPTED SOLUTION

I currenly have the V1000H... only major complaint is the lack of port forwarding that was available on my previous Telus modem (Zyxel?).

 

Range was fixed with 12db antennas.

View solution in original post

8 REPLIES 8

nasty
Rockstar

They tend to put the "this product is no longer available for sale" on products that are still being worked on and on those that have expired. They don't update their pages in a fastidious fashion, due to sales being mainly to corporations.

 

 

rayrayjj
Rockstar
Why is Telus the only company I can find that uses the t1200?

rayrayjj
Rockstar
I'm not saying there bad,I love my t1200 and wcb 3000 WiFi extender, get 5g with it.

rayrayjj
Rockstar
Anyone else like the t1200??


rayrayj-wrote:
Anyone else like the t1200??

Hey! Newbie-you know what don't takeMe wrong, but I've no idea what (Actiontec t1200-Stand for) Acronyms or unknown devices, should be explained to better understand. That's what I do. I was all mess up-when I start in the forum & read these terms-I'm not familiar with. You said is a router-isn't it,.ok rayrayj..Bye <v9>

 

@SA-Thks for the tip. I entered "Actiontec t1200" on the Google search-So is a router. I'll look it in Best Buy-I've plans to buy-1

 

 



 

 

@v9-12 yrs.Telus mobile user & Ex-BC Tel cable installer.
Find this reply useful-Give likes to his author
The future is unknown?


@rayrayj wrote:
Anyone else like the t1200??

I have used the T1200 for a customer of mine.  Easy to put in Bridge Mode and use a real router.  🙂

 

 

v9; google search is your friend.

I personally have an actiontec router at home (not sure of the model, I'd have to look it up( and it's served me pretty well. 

I currenly have the V1000H... only major complaint is the lack of port forwarding that was available on my previous Telus modem (Zyxel?).

 

Range was fixed with 12db antennas.

View solution in original post