Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Access Sportsnet Now

Just Moved In

I've created a 'My Account' and all my services are linked properly through it, but when I try to access Sportsnet Now through the Sportsnet website I'm told my username/password is incorrect. The username and password I used was the same I use to login to My Account. Please help.


Community Power User
Community Power User
Have you created an account here?

Keep in mind you also need to subscribe to Sportsnet channels so you can access the Sportsnet now live channels.

I tested my account an logged in without issue.

I have done this, set up an account using the Optik box and the confirm email code. Sign in at Optik on the Go works with no problem. But when I go to SN Now sign in and hit the Telus button the Telus pop up page to sign in opens, I type my info in hit the sign in button and only get this:



Community Power User
Community Power User

Do you currently subscribe to Sportsnet?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

Yes I do!

This same thing is happening for me. I have telus optik tv and Sportsnet Now was working for me just a few weeks ago. Now when I try to log in to Sportsnet Now, I'm getting the not a valid email address or password response. I've signed into my telus account and optik on the go account and they work fine. Just Sportsnet Now is what I am having issues with and I don't know why.



Hi I have figured out the problem  that neither the techs at Telus or Sportsnet could help us with as they both would write back it was the other guys fault.  Well it turns out with a lot of trail and error and resets, that it turns out to be Sportsnet fault. I had to change my Telus Optik password to NO MORE than 10 characters as Sportsnet log-in does not accept more than 10 characters. So if your Telus password, as mine was is longer than 10  characters you will have to make sure it change it. And now I can log in  to Sportsnet. 

Just Moved In

My password is only 8 characters and still can't access/sign in to SNNOW. May be the password had to be very complicated.

Thanks @Oh for figuring this out. I was going to jump in and say this is definitely an issue on the Sportsnet side, but you beat me to it! Hope this helps everyone else's concerns!

I too am recently unable to access sportsnet with my Telus account while it seems the length of password seems to have worked for @Oh, I have not had success.  I recently had an upgrade on my pvr at home, I'm not sure if this is the cause of my problems.  I have tried to create an account with my new pvr box but it will not allow that.  I talked to someone at Telus and it seemed that that is not being used anymore, confusing yes, then why is it still an option from the menu. The person that I talked to steered me towards Telus on the go, the sad thing is I have not had success watching sports with it, it's great for watching Magnum P.I. but not hockey.  It was nice when I could access sportsnet and watch a game that was played the day before.  Now one of the main reasons I have kept my cable package is now not working.  This now makes me wonder if I have made a mistake remaining a cable subscriber.