Showing results for 
Show  only  | Search instead for 
Did you mean: 

Telus Assistant fails to register on Google Home

I attempted to link the Telus assistant to my Google home but it keeps failing. I believe it's because I accidentally used the wrong Telus account, however I cannot find a way to change the login information. Before I completely delete my Google Home and recreate everything from scratch, anyone know how to change the account information?


Issue resolved. I logged onto my Google account. I had looked under 3rd party links previously and found nothing. I deleted my Home, re-created and nothing. I went back to my Google account and under Linked accounts, I found the Telus Home Assistant link. I deleted it, then finally was able to add the Telus Home Assistant successfully.

@WalterThompsonSunday Thanks for the information on the issues you had the first time you attempted to link your account, and happy to hear that after troubleshooting you were successful! Let me know if there are any other issues you encounter when trying to use the skill. 

I’m having exactly the same problem. How did you find the section for linked accounts to delete the wrong TELUS account I linked?

Go to Google .com and log into your account.
Click on your profile icon to open your account settings.
On the left select Security.
Scroll to the bottom of the page and select Linked accounts.
Find the Telus Assistant and unlink it.
Took me for ever the first time, seems so simple once you know where to look!


What steps are you taking?  I had some difficulty setting it up at first, as it wasn't properly loading on Google Assistant. I also believe you need to be on Fibre.

Community Power User
Community Power User
Can be on copper or fibre..


I'm also having an issue with linking, but I think the problem is it does not see the optik boxes. When I link via Google Home, and then sign in and allow Telus/Google to integrate, it just goes back to the setup screen and my optik boxes do not show up. I can unlink Telus (not via the GH App, but via as described below), so it is linking. I had the same problem with Telus Assistant BETA, but the moment I signed in using my Optik account (instead of My Telus), everything worked. Now that Telus Assistant has officially launched, how can you sign in via your Optik Credentials?

Thanks Telus. The issue has been resolved. I'm able to link my optik boxes to GH again.

Friendly Neighbour

I am experiencing the problem you listed above after I converted from copper to fiber, do you know what was done to correct your problem?

@BreitDoogie wrote:

I am experiencing the problem you listed above after I converted from copper to fiber, do you know what was done to correct your problem?

Please explain what you mean by "after I converted from copper to fiber". Was the TELUS Assistant linked to your Google Home when you were on copper?


AFAIK it should still be linked after you switched to fiber. The only issue might be that your Optik boxes may have been assigned new IP addresses during the switch but even then it shouldn't matter. Did you keep your previous router or did you get a new router when you switched to fiber?

I believe there is a problem with this.


My boxes link and integrate, but they are not responding. Google says Telus Home Assistant is not available, when I check the Optik Boxes via the GH App, and I try to manually turn it on and off, its "not responding" and "Oops, something went wrong". I've linked and unlinked my account, still not working. It worked well for a few weeks after it was officially launched, but not now.

Friendly Neighbour

Yes the TELUS assistant was connected when I was on copper. I recently changed over to fiber as they finally got it installed in my neighborhood. I can not say exactly I guess when it stopped working as I do not recall if I had used the connection with fiber. I do still have the same router they just installed the new module. 


So what happened was I went to use them the other day and I got the error that they where not available at the time. I went into my google home and attempted to do a device sync, when this was done the cable boxes disappeared from my devices. When I attempted to reconnect themI got a message that telus was connected, then the screen flashed once and went back to the add devices screen. I never got a chance to add any boxes to the rooms. I have tried going into my google account and removing the account link, then I get the My telus login screen, but get the same results after entering my information. It shows that telus has been linked, flashes for a second then goes back to the add devices screen.

after you login via GH and link your account, go back to the main GH screen and scroll to the bottom. They will be there and you should be able to add it to your home and rooms by clicking on the unassigned Optik Box.


After you do this, do they work with Google Assistant?

Friendly Neighbour

There are no Optik Boxes listed at the bottom. I have also attempted to see if they work in google assistant and they do not work there either. 

Interesting. This is the problem that I had before, its seems to be back. I've always found to the linking to be hit or miss. Since this now an official product, you might want to try tech support.


Does anybody's work?

Friendly Neighbour

I have tired telus support there official stance appears to be they don't support third party devices and that I should contact Google home. I have tentatively reached out to google home support and did not make to much progress. I feel the problem is on the telus side but now that they have moved beyond the beta test and can advertise that they have released it they don't care to support.