TELUS instructions re ssl conflict?

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Bpruner
Friendly Neighbour

confused on the correct ssl and port settings for imap on my imac

 

 

Here says no ssl :

 

http://business.telus.com/en/business/support/collaboration/business-email/how-to/how-to-set-up-your...

 

 

Here says use ssl

 

 

http://www.telus.com/en/bc/support/article/set-up-telus-email-apple-mail

 

Does anyone know which article is correct ? TELUS , can you update your documentation so it is consistent ?

 

 

 

 

Community Power User
Community Power User

Do you have a Business or Home account? The first URL you listed is business specific. If you just have a home account, use the second link.

 

Are you having a problem using email itself after setting up the account on your Mac? If yes, what error message are you receiving?


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
Bpruner
Friendly Neighbour

I have a Home account.


What is confusing me is the servers are the same in either case in the instructions, but the login instructions are different.

 

At any rate, if i deselect SSL (which it says i should if i follow the instructions) - it does not connect, and i get this error message when I run the 'Mail Connection Doctor' for both the IMAP and SMTP Servers - "could not connect to this TELUS imap server. Check your network connection and that you entered the correct info in the account preferences. Also verify that the server supports SSL, if it does not, deselect the 'use ssl' checkbox in the advanced tab of the account preferences'

 

if i check the log - i see this "INITIATING CONNECTION Feb 20 10:13:13.797 host:imap.telus.net -- port:993 -- socket:0x0 -- thread:0x61800086e100"

Bpruner
Friendly Neighbour

to further clarify (and thinks guys for your help) , it seems to fail in either setting (with ssl or not), it will periodically work and then stop for some reason which is frustrating to say the least. I have noted, when i use my iPhone (with the same setting) it doesn't work via my home wifi (telus); but does work when i switch to LTE...same goes for our IPADs. 

 

Is it possible that somehow a port is being blocked on my telus router as the behaviour would seem to suggest that it is router related given it works when i connect via LTE and not when I connect via home wifi?

Bpruner
Friendly Neighbour

here is the log string

 

Feb 15 11:44:27 iMac-4.local Mail[414] <Debug>: <bmpruner@telus.net@imap.telus.net> Background fetch completed: S{MFLibraryIMAPStore <MFMailbox: 0x7fbbf3e1b450> Inbox - Telus A{Telus IMAP - 1C1D378C-B307-4BA7-9F7C-12EEEAF4B0DB}} fetching for checking new mail, but could not get gateway

Most Helpful
Community Power User
Community Power User

Just a note: Telus personal email used to be port 143 and no SSL; it has been changed to port 993 and SSL, a better option in my opinion, as it should provide a more secure access to your email from a variety of locations which may or may not be Telus connections.

 

 

NFtoBC
If you find a post useful, please give the author a "Like"
Community Power User
Community Power User

Here are my settings:

  • Open Mail, choose Mail > Preferences
  • In the Accounts tab, choose Account information button > Outgoing mail server > press on the selector at the right edge of the selection box and choose 'Edit SMTP Server List'.
  • On that list choose Telus. 
  • Select the 'Account Information button and ensure the description is Telus (or similar) server name is smtp.telus.net. TLS certificate = none.
  • Select the 'Advanced' button. Turn off 'Automatically detected maintain account settings',  set port to 1025 and use SSL. Choose Authentication: Password and enter your login credentials. Press OK.

Back to the Accounts screen

  • Choose 'Advanced' to the right of 'Mailbox Behaviours'
  • IMAP Path Prefix should be blank
  • Port = 993; Use SSL is on
  • Authentication is password
  • Allow Insecure Authentication is unchecked.
  • Use Idle command.... is checked.

I am able to send and receive with these settings.

 

Note: I am unable to access my account through the Internet Accounts  pane. [ Mail > Accounts > Telus]

 

I get a login credentials error, and I have to check this further.

EDIT: Deleted and recreated the account in the Internet Accounts pane, and all works as expected.

 

 

 

 

 

 

NFtoBC
If you find a post useful, please give the author a "Like"
Bpruner
Friendly Neighbour

thank you so much for taking the time!

 

I set to those settings - its weird...because it will allow me to receive mail...and then, explicably, it goes back into the error state (exclamation point next to mailbox name)  - and then i get a message like:

 

"There may be a problem with the mail server or network. Verify the settings for account “Telus” or try again.

The server returned the error: The connection to the server “imap.telus.net” on port 993 timed out."

 

If i try the 'connection doctor' it also fails to connect , if i check the logs i get this message:

"Feb 15 15:17:12 iMac-4.local Mail[414] <Debug>: <[my email address]@telus.net@imap.telus.net> Background fetch completed: S{MFLibraryIMAPStore <MFMailbox: 0x7fbbf3e1f630> 808708C1-8282-469D-8C39-E0A080CF192B <12 chars> A{Telus IMAP - 1C1D378C-B307-4BA7-9F7C-12EEEAF4B0DB}} fetching for checking new mail, but could not get gateway

 

 

What is really weird is, if i drop my wifi connection and connect via LTE (a hotspot from my cell phone) it connects right away...which again has me thinking it has something to do with my wifi, not my account settings....ideas?

Community Power User
Community Power User

Can you connect your computer to the router by Ethernet cable and see what happens?

 

Also, what happens if you try port 143 instead of 993?

 

Finally, is 'Automatically detect and maintain account settings' and 'Include when automatically checking for new messages'  checked in Mail > Preferences > Accounts > Advanced?

 

 

NFtoBC
If you find a post useful, please give the author a "Like"
Bpruner
Friendly Neighbour

when i go via LAN cable instead of WIFI - i get the same intermittent error mesage

 

"The server returned the error: The connection to the server “imap.telus.net” on port 993 timed out."

 

I have tried switching it to port 143 and i will try that for a while and see if it works - earlier you had suggested i don't do the 'auto update settings' thing...let me try the 143 port thing first and see if that is any better.

 

Is it possible another application is blocking the port? I just find it odd that the connection is timing out? It seems to be a network issue which is re-enforced for me when problems clear up when i connect via LTE vs. my TELUS router.

 

thanks again for your help

Bpruner
Friendly Neighbour

same timeout issue now connecting to port 143

 

If experience is any guide...the error will clear itself after a while, then crop up again...any other ideas?

Community Power User
Community Power User

@Bpruner wrote:

when i go via LAN cable instead of WIFI - i get the same intermittent error mesage

 

"The server returned the error: The connection to the server “imap.telus.net” on port 993 timed out."

 

I have tried switching it to port 143 and i will try that for a while and see if it works - earlier you had suggested i don't do the 'auto update settings' thing...let me try the 143 port thing first and see if that is any better.

 

Is it possible another application is blocking the port? I just find it odd that the connection is timing out? It seems to be a network issue which is re-enforced for me when problems clear up when i connect via LTE vs. my TELUS router.

 

thanks again for your help


You've now delved into this to a far greater depth than my knowledge takes me!

 

Might be time to see if the Internet Techs at Telus can offer more info, or if a new Gateway would fix things.

 

 

NFtoBC
If you find a post useful, please give the author a "Like"