cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Surround sound on optic tv not working

Nascarbrat
Friendly Neighbour

Just got the new installation of the optic tv, and now, surround sound (ss) not working.  I have a Yama HTR-4063 and a Panasonic Viera TV.  I've tried changing to ss on optic menu, settings, nothing.  My ss has a direct hdmi output to hdmi on tv, the optic box, direct hdmi to tv.  I've tried putting the hdmi from optic box to ss, then ss to tv, nothing.  I've switched cable and ports to check each, nothing.  The only way I get sound is thru my tv speakers, which I had to turn on.  They had to be off with my Shaw box for ss to work.  I've tried turning them on and off, and adjusted from stereo to ss on optic settings menu too.  Mute is not on.  Rebooted everything multiple times.  I'm at a loss, any ideas?

8 REPLIES 8

vishwa
Leader

I can think of two points to keep in mind. While you are trying, make sure you go back and the surround sound setting is saved.  Second, make sure you are in a channel that is broadcasting in surround sound.  Many channels only have stereo so if you happen to be on one of those, you will never get ss.

Nascarbrat
Friendly Neighbour

Thanks, but that's all good.

 

Nascarbrat
Friendly Neighbour

Something else to note, the volume control on the optic tv, only recognizes the tv speakers, i.e. It tells me speakers are off when I'm in the ss mode.  There has to be a way to tell the optic box that I have surround sound and to use it

 

 

20170325_123507.jpgdoes your screen look like this?

 

20170325_123507.jpg

 

Nascarbrat
Friendly Neighbour

No, I have that option, (to select either stereo or surround) but not the message about changing the channel

Nascarbrat
Friendly Neighbour

so an update on this, I see others having same issues.  What I did was plug HDMI out on my SS, to back of TV in port 2.  I then took the HDMI from optic box, apple tv, and android box, and plugged into the back of my ss.  If I change it to ss on the optic settings menu, the sound is not very good, so I've left it on stereo.  I also have an optic cable plugged from ss to optic box, this may be redundant.  My only problem now is my volume control on optic slim remote doesn't work, have to adjust it with the remote from the ss, and the channels are wonky, some very loud, some not.  I've found some info on here about setting tv to 25 on the volume, and reprogramming remote, I'll work on this and see if it helps.  Would really prefer to have the volume control on the Optic Slim Line remote.

You can actually have the Slimline 2 remote control both your TV and amplifier - but the instructions are not clear.  See  https://www.telus.com/en/bc/support/article/program-slimline-remote-2 step 5 ... when you enter a tv code the remote flashes red and when you enter an amplifier code it flashes yellow.  I have done this and the remote controls both my LG tv and Sony soundbar. So you need to program the remote once for the TV and once for the amplifier.  Hope this works for you.

Nascarbrat
Friendly Neighbour

Thank you! Am going to try that out, appreciate that!