Slow(er) Wifi on Actiontec 2200

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

Highlighted
Friendly Neighbour

I just switched over from Shaw this weekend and got a 100mbps connection with optik. I live in a condo and a wifi scan shows well over 20 available networks from my suite. My install came with an actiontec 2200h modem/router. The best speed I can get out of the router however is 40mbps on wifi, but I'll get 95mbps wired. 


Any suggestions as to what I can do?


Accepted Solutions
Highlighted
Most Helpful
Friendly Neighbour

Ok well I guess I solved it. First I read the manual, then I started to fiddle with the advanced wireless settings. I changed the channel width to 40mhz, keeping the control channel Lower, then I enabled MSDU aggregation and disabled MPDU aggregation. 


Now I'm getting decent speed tests for wifi:

http://www.speedtest.net/my-result/4424333522


I hope this helps anyone else with their setup!

View solution in original post


All Replies
Highlighted
Community Power User
Community Power User

Are you using wireless G or N? G has a theoretical max of 54mbps. N will be faster. I find that in areas where there are a lot of competing networks, wireless can suffer. One thing to try is to change the frequency / channel that the wireless is using. That worked for me with a similar number of networks nearby.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. πŸ™‚
Highlighted
Community Power User
Community Power User

Which version of Wifi is on the device you are connecting to the gateway? In addition to collisions from competing Wifi points, the distance you are from you gateway will cause slowing. High speed Wifi is often accomplished by using multiple bands at once. If your device is no so capable, your speeds won't match 100Mbps. More info will help the community help you. 


Also remember, 100Mbps is meant for multiple users to the gateway, not necessarily 100Mbps to a single user.


https://en.wikipedia.org/wiki/IEEE_802.11



 

NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
Friendly Neighbour

I have the gateway set to N only. I've tried changing the channel but I don't really get much change. My devices all use N to connect. 


Wired I get this as a speed test: 

http://www.speedtest.net/my-result/4413999387


And wireless I get this: 

http://www.speedtest.net/my-result/i/1267599675


So I know the gateway can handle 100mbps just not over WiFi. 

Highlighted
Community Power User
Community Power User

What devices! Just because you have a 100mbps connection doesn't mean that device can even reach those speeds on wifi.


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Friendly Neighbour

I'm using an iPhone 6 plus and a 2013 Macbook pro. Both are capable of 100+mbps on WiFi. At time of testing I'm about 5 feet from the router. 

Highlighted
Most Helpful
Friendly Neighbour

Ok well I guess I solved it. First I read the manual, then I started to fiddle with the advanced wireless settings. I changed the channel width to 40mhz, keeping the control channel Lower, then I enabled MSDU aggregation and disabled MPDU aggregation. 


Now I'm getting decent speed tests for wifi:

http://www.speedtest.net/my-result/4424333522


I hope this helps anyone else with their setup!

View solution in original post

Highlighted
Community Power User
Community Power User

Thanks for sharing your solution. Have you a link to the manual?


Please continue to follow the community and offer solutions for others.



NFtoBC
If you find a post useful, please give the author a "Like"
Highlighted
Community Power User
Community Power User

The 5ghz spectrum is when you select the 40mhz upper or lower range. Not many channel selections though. 


But chances are no one is using 137 etc. Most leave the settings stock.


What I don't like is if running optik TV. You can't use different DNS, well you can just apps like Netflix etc won't work. Sneaky Telus lol.


Also if you ever get the red light of death on a stb. It won't communicate with the Telus servers to re-download the software.


Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
Highlighted
Friendly Neighbour

NFtoBC 

Thanks for sharing your solution. Have you a link to the manual?


I found the link to the manual in the Advanced tab of the router setup (far right tab). Once you confirm you're an advanced user, just scroll to the bottom of the list on the left and you will find the link to the manual. 


WestCoasterBC

The 5ghz spectrum is when you select the 40mhz upper or lower range. Not many channel selections though. 


But chances are no one is using 137 etc. Most leave the settings stock.


I have no idea how to change my 5 ghz channel. Could you please direct me on how?