Port forwading not working

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

YYCGuy
Connector

I am trying to forward a port for the purposes of using Wake-on-LAN remotely. Try as I might, I cannot get a port to open so it is seen by any one of the many online "open port checking" tools.

 

This is my first time trying port forwarding, so please be kind in your replies as I am a beginner. Here's what I did, I suspect it may even be too much and/or not secure?

 

(1) Using the built in Windows (7) Networking tools, I created a static IP for my PC's network adapter. This looks fine.

(2) On the router, I added that same static IP to the DHCP Reservation Table. This also looks fine.

(3) I tried to forward a few random ports (I am aware of the ports Telus has closed). Using a tutorial I found online, I used the same port number 4 times for each port - WAN Start/End and LAN Start/End. This doesn't sound so fine to me but I couldn't find another guide.

(4) Based on previous posts I've seen on the community, I disabled IPv6 for LAN and WAN and set the firewall for NAT only.

(5) I opened the same ports on Windows Firewall (is this even necessary?)

 

Despite all this, my chosen port appear closed externally. What am I doing wrong? Any help or guidance is much appreciated.

YYCGuy
Connector

Sorry, should have mentioned router is an Actiontec T3200M.

Community Power User
Community Power User

And the port you wish to forward is.....?

 

NFtoBC
If you find a post useful, please give the author a "Like"
YYCGuy
Connector

my little Android WoL app defaults to port 9 but documentation states it can use any port. So 've tried 9 on the router, also 48, 3074 on router and app, no joy. Just random port numbers.

DeanD
Coach

Wake on LAN does use UDP port 9 in most cases.  Now with that said, usually when a machine is off, you have to piggyback that signal to the machine you wish to wake up.  That means, usually you have to find a machine on the local lan that is on, and that machine will send the WoL packet to the target machine.  

 

Now here is where it gets tricky.  You really want to test this first on the local lan.  Usually, there is a CMOS/BIOS setting to enable WoL.  Then sometimes there is also a driver setting on the target machine.  To do this, I usually use a remote access agent to send to WoL packet, as it usually doesn't just go to an IP address, it's usually directed to a MAC address, as the IP stack is not initialized when a machine is off.  Things like Team Viewer, etc now support WoL, which will be much easier to get running than a pure client.

YYCGuy
Connector

I don't ever power my laptop down, it's just in Sleep Mode. And my local LAN wake works fine. I had already enabled WoL as well as Wireless WoL in my laptop's BIOS. I had also already configured the network adapter to allow the magic packet to wake the computer, and have disabled Energy Efficient Ethernet. I then hardcoded the adapter's MAC into my (android) WoL app, and my PC awakes from sleep no problem. However, no such luck over a remote wifi network or when using cellular data.

Are you saying I need another machine to wake my target machine up, rather than just having my WoL app send the wake packet directly to the target? I haven't come across that advice in my research, and it seems like an extra and unnecessary hop (?) The only other internet enabled devices that I have on my little home network that are always on are a Chromecast attached to my TV, and the Telus PVR. But I doubt these count as devices?

Also, I'm still wondering which one(s) of these three I should disable, all 3 seem like overkill and potential conflict or security issues:

(1) Static IP assigned through Windows networking tools (192.168.1.xxx)

(2) Same static IP added to the DHCP Reservation Table on the router

(3) Opening same ports on Windows Firewall as the ports I am trying to forward on the router.


Thanks!

Highlighted
Most Helpful
DeanD
Coach

@YYCGuy wrote:

I don't ever power my laptop down, it's just in Sleep Mode. And my local LAN wake works fine. I had already enabled WoL as well as Wireless WoL in my laptop's BIOS. I had also already configured the network adapter to allow the magic packet to wake the computer, and have disabled Energy Efficient Ethernet. I then hardcoded the adapter's MAC into my (android) WoL app, and my PC awakes from sleep no problem. However, no such luck over a remote wifi network or when using cellular data.

Are you saying I need another machine to wake my target machine up, rather than just having my WoL app send the wake packet directly to the target? I haven't come across that advice in my research, and it seems like an extra and unnecessary hop (?) The only other internet enabled devices that I have on my little home network that are always on are a Chromecast attached to my TV, and the Telus PVR. But I doubt these count as devices?

Also, I'm still wondering which one(s) of these three I should disable, all 3 seem like overkill and potential conflict or security issues:

(1) Static IP assigned through Windows networking tools (192.168.1.xxx)

(2) Same static IP added to the DHCP Reservation Table on the router

(3) Opening same ports on Windows Firewall as the ports I am trying to forward on the router.

 

Thanks!


The main problem is that when you are on the LAN or WiFi, you have local access, so the mac addresses are discoverable via ARP (Address Resolution Protocol).  When you try to send a packet to a mac over the internet, the internet has no real way to know which gateway to send that packet, which then would say "Yes, I have that mac in my table, I'll send it to this hardware address".  

 

So to make it work, first the firewall you are using, in this case, would be the Telus T3200.  Since the magic packet is a broadcast packet to a mac, you would have to forward the packet as a broadcast.  Not all routers will support this.  So in this case, you would state that 192.168.1.255 is the address to send the packet over UDP port 9 back to.

 

Try this:  https://www.howtogeek.com/192642/how-to-remotely-turn-on-your-pc-over-the-internet/

 

I'm not sure if the telus router will port forward back to a broadcast address.  I don't really use the Telus gateway myself.  I use my own router with bridging mode on port 1, which my router is plugged into.  That way, I get my router setup, and I leave the telus gateway for just my PVR box.  I find I get more control with my own router vs the Telus one.

 

If they have a DMZ mode, you can place your laptop into the the DMZ port and just have all packets forwarded to that device, but that can also expose your laptop to bad traffic.  It might be better to just subscribe to a service like Team Viewer and let them send a WoL packet back to wake your notebook up.

 

 

YYCGuy
Connector

@DeanD wrote:

@YYCGuy wrote:

I don't ever power my laptop down, it's just in Sleep Mode. And my local LAN wake works fine. I had already enabled WoL as well as Wireless WoL in my laptop's BIOS. I had also already configured the network adapter to allow the magic packet to wake the computer, and have disabled Energy Efficient Ethernet. I then hardcoded the adapter's MAC into my (android) WoL app, and my PC awakes from sleep no problem. However, no such luck over a remote wifi network or when using cellular data.

Are you saying I need another machine to wake my target machine up, rather than just having my WoL app send the wake packet directly to the target? I haven't come across that advice in my research, and it seems like an extra and unnecessary hop (?) The only other internet enabled devices that I have on my little home network that are always on are a Chromecast attached to my TV, and the Telus PVR. But I doubt these count as devices?

Also, I'm still wondering which one(s) of these three I should disable, all 3 seem like overkill and potential conflict or security issues:

(1) Static IP assigned through Windows networking tools (192.168.1.xxx)

(2) Same static IP added to the DHCP Reservation Table on the router

(3) Opening same ports on Windows Firewall as the ports I am trying to forward on the router.

 

Thanks!


The main problem is that when you are on the LAN or WiFi, you have local access, so the mac addresses are discoverable via ARP (Address Resolution Protocol).  When you try to send a packet to a mac over the internet, the internet has no real way to know which gateway to send that packet, which then would say "Yes, I have that mac in my table, I'll send it to this hardware address".  

 

So to make it work, first the firewall you are using, in this case, would be the Telus T3200.  Since the magic packet is a broadcast packet to a mac, you would have to forward the packet as a broadcast.  Not all routers will support this.  So in this case, you would state that 192.168.1.255 is the address to send the packet over UDP port 9 back to.

 

Try this:  https://www.howtogeek.com/192642/how-to-remotely-turn-on-your-pc-over-the-internet/

 

I'm not sure if the telus router will port forward back to a broadcast address.  I don't really use the Telus gateway myself.  I use my own router with bridging mode on port 1, which my router is plugged into.  That way, I get my router setup, and I leave the telus gateway for just my PVR box.  I find I get more control with my own router vs the Telus one.

 

If they have a DMZ mode, you can place your laptop into the the DMZ port and just have all packets forwarded to that device, but that can also expose your laptop to bad traffic.  It might be better to just subscribe to a service like Team Viewer and let them send a WoL packet back to wake your notebook up.

 

 




YYCGuy
Connector

@DeanD, I don't know why I didn't get a notification to your reply two weeks ago until just today. But better late than never: thank you very much for this educational and helpful response. WoL has fallen off my radar a little, but I will resurrect using your info and that HTG article you sent.

Re: DMZ, I believe I saw a DMZ option on the gateway but am not crazy about security issues there. I'll fiddle with Port 9 UDP config a little and if I don't get lucky quickly, will indeed go with TeamViewer. Free for personal use so that's nice. Ironically though, this was the extra software bulk I was trying to avoid all along... lol

 

Thanks again Dean.