Showing results for 
Show  only  | Search instead for 
Did you mean: 

No IPv6 on one Mac computer (Solved)


All of the computers in my house are Macs and they all get IPv6 addresses except one. All of the computers are on the latest macOS 10.13.4 (High Sierra) but one is older and only supports 10.11.6 (El Capitan). All of the system settings are the same, but the older one is not getting an IPv6 address. All of the searching I have done says that IPv6 is fully supported on every version of macOS since 10.6 (Snow Leopard) and it should be working. I am fairly certain is was working when I upgraded to Internet 50 and this new Actiontec T3200 router. The Actiontec was factory reset a few days ago (which caused a firmware update) and only the wireless settings were changed and some DHCP entries for the devices we have.


Does anyone know why this would be?


Community Power User
Community Power User

It'll be something on the one Mac. You're sure IPv6 is enabled in the Network settings? Is it wired? Wireless?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

It is. The MacPro (2009) is wired to a smart switch which is connected to the Actiontec router directly. The network settings are the same as the other computers.

Screen Shot 2018-05-11 at 6.22.55 PM.png




















When I run ifconfig on the computer, all I see is a link-local address. The other computers are getting 2 IPv6 addresses as expected.

ifconfig en0
	ether 00:1d:4f:xx:xx:xx 
	inet6 fe80::21d:4fff:fexx:xxxx%en0 prefixlen 64 scopeid 0x4 
	inet netmask 0xffffff00 broadcast
	nd6 options=1<PERFORMNUD>
	media: autoselect (1000baseT <full-duplex,flow-control>)
	status: active


Community Power User
Community Power User

What happens if you move the Ethernet cable to another of the 4 ports on the Actiontec? Try swapping with one of the ports serving IPv6 to one of your other Macs.


If you find a post useful, please give the author a "Kudo"

Community Power User
Community Power User

Do you have your own router in addition to the T3200? A regular switch won't have it's own IP and won't give out device IPs either. A router will. Your gateway IP is showing as If the T3200 was reset it would default to Usually the first device IP it hands out ends in .1.64 and goes up from there. Something about your configuration is not standard. If that "smart switch" is a router, and that's the only thing different from the rest of your devices, fair chance it could be the cause.

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

I do have an Airport Time Capsule (802.11ac) and an older AirPort Extreme Base Station (802.11n) but they are both set to Bridge Mode (no router services) and are being used to extend/stabilize the wireless network only. No other routing devices are on the network.
The reason the IPs are 192.168.95.xx is that I am running a local DNS and all devices are coded to that network range. It is easier to change the LAN IP settings on the Actiontec to .95 than it is to change all of the DNS entries to .1. 

All wired devices on the network are connected to the smart switch. The only devices connected to the Actiontec are the 4K PVR and the OpticTV STB (both wired).
In any case, I moved the Ethernet cable that connects the switch to port 4 on the Actiontec (it was on port 1), but it had no effect. I also tried power cycling the switch, but it also had no effect.
I am going to try a temporary cable from the MacPro directly to the Actiontec to eliminate the switch from the equation. I am not sure it will help as all other wired devices are working as expected.
Thanks for the suggestion.


I tried a few other tests today.


1. I connected the MacPro directly to the Actiontec router and no IPv6 address was issued by DHCP/Autoconfig.


2. I connected a USB-Ethernet dongle to the MacPro and it it also did not get an IPv6 address. (The same dongle works fine with an old MacBook Air running macOS High Sierra).


I would like to try setting the IPv6 settings manually (as a test only). How do I know what settings to use for this?

Just in case someone else has a similar issue, I did some more testing and found a solution.


I re-installed the same OS on a different partition and IPv6 addresses were obtained from the router. I then re-installed the same OS on my existing boot drive and that solved the problem.