cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Mac Mail - Multiple email Accounts - problem with "Reply To" address

mycroft
Neighbour

My wife has a MacBook Pro (10.8.2) with a Telus home internet connection. She uses the Mac mail app and her primary email account is a Gmail address, which she has been using with no problem (using Gmail's imap and smtp servers).

 

She recently asked me to set up another Gmail account, which I did, but whenever she sends a new email, the Reply To address is for her original account. In an effort to trouble shoot the problem, I activated her Telus email account, which she does not normally use.

 

Here's the setup:

 

1. Gmail account (primary account)         imap.gmail.com    smtp.gmail.com (with password authentication)

2. Gmail account (new account)               imap.gmail.com    smtp.gmail.com (with password authentication)

3. Telus account                                       imap.telus.net    smtp.telus.net (with no authentication)   

 

She can send and receive from all three accounts, but the Reply To address is always account no. 1.

 

She selects the correct account in the drop-down From menu when composing her email

 

Each account has its own smtp setup, with the correct name and password in the authentication, in the case of the Gmail accounts. 

 

Does anyone have any idea how to fix this?

1 ACCEPTED SOLUTION

Hi NFtoBC,

 

I've solved the problem - it was my faulty memory Smiley Wink

 

I had forgotten that a long time ago, I had set 'Reply To' for all email accounts, using a command line in the Terminal.

I reset the defaults, by executing 'defaults delete com.apple.mail UserHeaders' in the Terminal.

All three accounts now work as expected.

 

Apple really ought to smarten up and make their email app much more user friendly. NOBODY should have to use the command line for configuration anymore.

View solution in original post

5 REPLIES 5

NFtoBC
Community Power User
Community Power User

@mycroft 

Thanks for the clear description of your problems with Mail.

 

I have multiple accouts as well, but not your challenge. is it possible the reply to field holds her initial gmail address? The fields can be displayed by using the drop down selection box to the left of the from field.

 

Also, make sure in Mail> Preferences > Composing that the selection 'Send new messages from:' is set to 'Account of selected mailbox' rather than one of the individual accounts.

 

 

Please let us know if this works.

 

NFtoBC
If you find a post useful, please give the author a "Like"

Hi NFtoBC,

 

I've solved the problem - it was my faulty memory Smiley Wink

 

I had forgotten that a long time ago, I had set 'Reply To' for all email accounts, using a command line in the Terminal.

I reset the defaults, by executing 'defaults delete com.apple.mail UserHeaders' in the Terminal.

All three accounts now work as expected.

 

Apple really ought to smarten up and make their email app much more user friendly. NOBODY should have to use the command line for configuration anymore.

View solution in original post

NFtoBC
Community Power User
Community Power User

@mycroft As indicated above, global Reply-To can be managed through the preferences pane. No need to configure this through the comand line.  Of course, since you had done it that way, you needed reverse it by the same method!

 

Glad to learn you solved it!  Thanks for letting us know.

 

 

NFtoBC
If you find a post useful, please give the author a "Like"

NFtoBC,

 

Can you tell me where in the Preferences pane?

NFtoBC
Community Power User
Community Power User

Here you go!

Screen Shot 2014-05-25 at 10.00.55 AM.png

NFtoBC
If you find a post useful, please give the author a "Like"