Showing results for 
Show  only  | Search instead for 
Did you mean: 

Lower internet speed when T3200M bridged


I just had my internet service upgraded to Internet 150 on PureFibre in Kelowna.


The technician set up the modem in bridge mode, same as my previous T1200.


If I connect to the T3200M using 5GHz wireless, I can get 150+ Mbps internet speeds.


However, everything that connects through my Asus router connected to the bridge port (port 1 on the T3200M) sees a maximum speed of 100 Mbps.  Wired and wireless.


I found this out while the tech was still at the house, and of course we both thought that the problem was a 100 Mbps wired adapter somewhere in the mix.  I spent most of today trying to figure out where it was and I couldn't.


So I took the T3200M out of bridge mode and tried that.  Bam!  150 Mbps internet speed available through wired and wireless connections to my Asus router (well, a router now acting as a switch).  This is with router reconfiguration only.  I made absolutely no changes made to the ethernet cables or the ports they were connected to (the Asus router allows me to reassign the WAN port as a LAN port).


I assume that one of two things is happening:


1.  My bridge IP address is somehow limited to 100 Mbps (but not the IP address assigned to the T3200M)

2. When in bridged mode, the ethernet ports on the T3200M are limited to 100 Mbps.


I believe it is number 2 because I cannot get 150 Mbps with wired devices connected directly ports 2-4 on the T3200M when it is in bridge mode.


That router's cpu doesn't have the power to give you the full speed. 

View solution in original post


Community Power User
Community Power User

I, and others, run a secondary router un-bridged on the T3200M without difficulty. Is there a reason you need the bridged port?


If you find a post useful, please give the author a "Kudo"

Yes - I run OpenVPN on the Asus router.

Community Power User
Community Power User

What model is the Asus router?

If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

RT-N66U running DD-WRT firmware.   How can that make any difference?

That router's cpu doesn't have the power to give you the full speed. 

I'm not sure what you mean.  It can route gigabit traffic on the local network no problem.  And when I turn off the Port 1 bridge on the Actiontec, I get full internet speed (150+ Mbps) switched through the Asus.

I am not sure about the policy on putting an external link here.  The explanation is a bit long.  Essentially, if you have setup the router with openvpn client and the traffic goes through the tunnel, there a lot of calculations to be performed and the router model you have(or even the higher ones) don't have the muscle to do it.  In fact, the general advice a couple of years ago(while I was looking into it) was the the consumer level routers just can't keep up with openvpn. 

If you do a search with 'openvpn router speeds' there is a very detailed thread on PIA.  That will give you a lot of information.  The reason you get good speeds without openvpn is that Asus has CTF(cut through forwarding).

Thanks.  I did some research after your previous reply and found the issues with DD-WRT and WAN speed.  Newer versions of DD-WRT support an optimization similar to CTF called SFE.  It does seem to help, but the newer versions seem to have broken OpenVPN.


Working on it now, and I appreciate you putting me on the right path.  Hoping to avoid buying a new router ...

After all the research and trying, if you do decide to buy a new one, get one with a dual cpu and high GHz. Two best examples(there are many) are Linksys wrt1900ac V2(1.6 GHz, or even WRT1200AC) and the AC1900 version of Asus RT-Ac68(Best buy has it) which runs at 1.4GHz.  For the latter, if you use Merlin firmware, OpenVPN client  1 always uses CPU 2. For the WRT1900/1200 DD-WRT works great.

As an additional point, if you haven't already done this, if you setup policy rules on the router, only those use the tunnel and the rest use regular(ISP) route giving you full speed.

One recent example from the net. You can read more on DD-WRT forum on the Broadcom section.  


I wish I could rename this thread, which would be more accurately called "How to configure an ASUS RT-N66U for Internet 150 service".


There was no problem with the Actiontec T3200M.


The problem is that my router, when running an older version of DD-WRT firmware, did not have sufficient speed to provide routing for 150 Mbps service.


However, by installing a newer version of the DD-WRT firmware (33986 if you really care), which implements a "shortcut forwarding engine" (SFE), the routing speed handles the full 150 Mbps connection.  Even which used with OpenVPN.


Thanks to the folks on this forum.

Community Power User
Community Power User


There is no issue with posting legitimate links to resources here in the Neighbourhood. 


Now, if you post about “a Essay Writing Services.......”  🤡



If you find a post useful, please give the author a "Kudo"


Thanks. Wasn't sure.  For the future.