Latency/Ping issue to EA NHL 19 Servers

Reply
JMO21
Friendly Neighbour

I live in Edmonton and have Telus PureFibre Internet 150. In about half of my online games I experience a noticeable half second between when I press a button on my controller and when my player does the action in the game. It's pretty frustrating and really deters from the online experience. A couple of my buddies on my club team have Shaw and have never experienced this "input delay". I happen to work out of town during the week and the place I stay at has Shaw as ISP, so one day I decided to run a traceroute to easo.ea.com (that's what EA says to do to check any connections issues). The results are below, both to easo.ea.com from Shaw and Telus. 

 

SHAW:

 

1 192.168.0.1 (192.168.0.1) 3.018 ms 7.467 ms 2.542 ms
2 174.0.128.1 (174.0.128.1) 13.967 ms 20.278 ms 12.882 ms
3 rd5he-tge0-2-4-0-1.rd.shawcable.net (64.59.133.61) 30.205 ms 29.833 ms 24.538 ms
4 rc1we-be2.ed.shawcable.net (66.163.76.49) 72.617 ms 34.068 ms 22.880 ms
5 rc3no-be6.cg.shawcable.net (66.163.64.69) 27.292 ms 29.587 ms 23.559 ms
6 rc2nr-be110-1.wp.shawcable.net (66.163.76.58) 46.355 ms 40.231 ms 39.237 ms
7 rc3fs-hge0-7-0-0.mt.shawcable.net (66.163.76.22) 80.003 ms 69.085 ms 73.701 ms
8 rc1eqn-tge0-0-0-0.uk.shawcable.net (66.163.78.146) 72.541 ms 69.878 ms 73.089 ms
9 rc3ar-tge0-14-0-7.ed.shawcable.net (66.163.75.81) 82.576 ms 76.756 ms 80.435 ms
10 ge-4-1-0.mpr1.iad10.us.mfnx.net (206.126.236.86) 78.478 ms 76.201 ms 73.753 ms
11 ae22.cr2.dca2.us.zip.zayo.com (64.125.29.122) 84.458 ms 84.142 ms 75.918 ms
12 ae1.er2.iad10.us.zip.zayo.com (64.125.20.122) 82.744 ms 83.431 ms 78.124 ms
13 64.125.199.190.t00673-02.above.net (64.125.199.190) 78.066 ms 78.576 ms 84.041 ms
14 159.153.92.98 (159.153.92.98) 81.048 ms 80.018 ms 83.125 ms

 

TELUS:

 

1 192.168.1.254 (192.168.1.254) 5.706 ms 2.771 ms 0.877 ms
2 10.139.54.1 (10.139.54.1) 2.474 ms 2.485 ms 3.356 ms
3 sttlwawbci01.bb.telus.com (75.154.217.108) 22.518 ms 22.433 ms
sttlwawbci01.bb.telus.com (75.154.217.106) 24.092 ms
4 96.1.252.164 (96.1.252.164) 23.580 ms 29.684 ms 26.927 ms
5 ae27.cs2.sea1.us.eth.zayo.com (64.125.29.2) 94.143 ms 106.881 ms 90.002 ms
6 ae2.cs2.ord2.us.eth.zayo.com (64.125.29.29) 130.679 ms 94.521 ms 94.844 ms
7 ae3.cs2.lga5.us.eth.zayo.com (64.125.29.212) 94.450 ms 94.510 ms 97.680 ms
8 ae4.cs2.dca2.us.eth.zayo.com (64.125.29.31) 95.911 ms 93.143 ms 104.526 ms
9 ae27.cr2.dca2.us.zip.zayo.com (64.125.30.249) 96.889 ms 98.276 ms 100.101 ms
10 ae1.er2.iad10.us.zip.zayo.com (64.125.20.122) 90.759 ms 104.923 ms 95.540 ms
11 64.125.199.190.t00673-02.above.net (64.125.199.190) 93.990 ms 161.707 ms 91.990 ms
12 159.153.92.98 (159.153.92.98) 95.306 ms 99.968 ms 110.541 ms

 

 

I'm not an expert in networking by any means, but it looks like the Telus route is 30ms slower to the server than the Shaw route. I know this is happening to other people too as this has been talked about on EA's forums. Would Telus be able to look into what exactly is going on here and why my ping times to the EA servers are slower compared to Shaw? Granted, NHL 19 is the only online game I have any issue with and EA is the worst, so it wouldn't surprise me if part of the issue is on EA's end. 

Community Power User
Community Power User

Is the device you are testing from on wifi? The latency to even the gateway for each seems way too high to be a hardwired connection. Do you have any other router in place besides the one provided by Telus? Is your console using wifi also?

 

One other thing to note is that the game server you connect to will not be easo.ea.com. That's just one they use for testing. The oddity is that if you enter that address in a browser, you get an error page for Pogo.com, which is a site EA bought out that hosts browser based games. Another thing I noticed is that if I traceroute to easo.ea.com I'm getting a different IP but that's probably because I'm using custom DNS on my router. (See 1.1.1.1) Even if I ping the IP you got, my results are only a couple milliseconds faster than the IP I originally got.

 

For me when I test from my connection, I get lower latency than both you and the Shaw test you did. The path my connection took looks basically the same as yours. 

 

|------------------------------------------------------------------------------------------|
|                                      WinMTR statistics                                   |
|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |
|------------------------------------------------|------|------|------|------|------|------|
|                           192.168.1.254 -    0 |   30 |   30 |    0 |    0 |    1 |    0 |
|                            10.145.148.1 -    0 |   30 |   30 |    4 |    8 |   24 |    8 |
|               sttlwawbci01.bb.telus.com -    0 |   30 |   30 |   24 |   24 |   27 |   24 |
|                   No response from host -  100 |    7 |    0 |    0 |    0 |    0 |    0 |
|           ae27.cs2.sea1.us.eth.zayo.com -    0 |   30 |   30 |   76 |   76 |   78 |   76 |
|            ae2.cs2.ord2.us.eth.zayo.com -    0 |   30 |   30 |   86 |   95 |  112 |   90 |
|            ae3.cs2.lga5.us.eth.zayo.com -    0 |   30 |   30 |   76 |   77 |   81 |   77 |
|            ae4.cs2.dca2.us.eth.zayo.com -    0 |   30 |   30 |   76 |   77 |   80 |   77 |
|           ae27.cr2.dca2.us.zip.zayo.com -    0 |   30 |   30 |   76 |   76 |   97 |   76 |
|           ae1.er2.iad10.us.zip.zayo.com -    0 |   30 |   30 |   77 |   77 |   81 |   78 |
|      64.125.199.190.t00673-02.above.net -    0 |   30 |   30 |   76 |   77 |   78 |   77 |
|                           159.153.92.98 -    0 |   30 |   30 |   77 |   77 |   78 |   77 |
|                           159.153.92.94 -    0 |   30 |   30 |   77 |   77 |   78 |   77 |
|                             easo.ea.com -    0 |   30 |   30 |   76 |   77 |   78 |   77 |
|________________________________________________|______|______|______|______|______|______|
   WinMTR v0.92 GPL V2

If you can locate the actual server for the game, try testing to that. EA does their best to hide the server addresses so it won't be easy.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
JMO21
Friendly Neighbour

@Nighthawk Thank you for the reply.

 

Sorry I should have clarified, yes both these tests were done on wifi using my Mac laptop and the Terminal application following EA's online connection testing instructions below:

 

  1. Open the Applications folder.
  2. Open the Utilities folder.
  3. Double-click Terminal.
  4. Type traceroute easo.ea.com > ~/Desktop/trace.txt in the terminal window.
  5. Hit Return.

However, my gaming console (PS4) is directly hardwired to my Telus T3200M router and that is the only router I have. I have setup up the google DNS Servers on my PS4 network connections settings (8.8.8.8 & 8.8.4.4) but do you think it would help if I changed the DNS setting in my router settings?

Community Power User
Community Power User

Changing DNS settings might help but it's not going to change the peering or path the connection takes to the server. A lot of EA's servers seem to be in California. From my past experience with game servers there, they've traditionally had inonsistent and higher pings. I wish more servers were in Chicago as I get sub 50ms pings to those ones.


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy
JMO21
Friendly Neighbour

@Nighthawk I see....what about using a VPN? Would that change the path the connection takes to the server or no?

Community Power User
Community Power User
Using a VPN will make it worse and not improve the latency. EA servers have notoriously had issues since having online game servers, especially on the west coast.

Find a post useful, please click on "Like" to give the author recognition or mark as an accepted solution.
JMO21
Friendly Neighbour

Thank you both for your input. It's strange too, never had issues on PS3. It just started with the next gen console PS4. Oh well.

 

**bleep** you EA!

Community Power User
Community Power User

@JMO21 wrote:

**bleep** you EA!


Welcome to the club! Cat LOL


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. Smiley Happy