cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Internet INSANELY slow.

JMDG
Just Moved In

I have a problem, I just moved to a new place and had my Telus service transferred and upgraded to 50 mbps + optik TV. For the first few days everything was fine speedtest confirmed that i was getting a 55 mbps download speed. However a couple days after installation I noticed my tv channels were all very chopy and constantly freezing "buffering" so I ran a speed test and it showed I was getting 5 mbps instead of 50! Then I ran a latency test and found to my dismay I was also experiencing a 20% packet loss and spikes from 15 ms to 200 ms! This lasted all day and then in the morning it was all fine.. untill today one week later I am having the same problem, can't watch TV and my connection times out 5 times out of 8 when im trying to load a simple web page! WHAT is going on, I'm living in a higher end 2008 built condo! This shouldn't be happening. (I'm plugged in via Ethernet with a brand new router) Ive tried calling Customer support and all that happens is I get put on hold for 20 freakin minutes. 

2 REPLIES 2

Nighthawk
Community Power User
Community Power User

Hate to say it but you'll have to talk to tech support. Sounds like a connection issue. Are you just using the modem/gateway that Telus provided or are you also using your own router?


If you find a post useful, please give the author a "Like" or mark as an accepted solution if it solves your trouble. 🙂

NFtoBC
Community Power User
Community Power User

When you call Tech Support, try first thing in the morning; there's usually a shorter line-up.

 

NFtoBC
If you find a post useful, please give the author a "Like"