IPv6 not working (Vancouver, Business PureFibre) - debugging with tcpdump etc

SOLVED
Connector

IPv6 not working (Vancouver, Business PureFibre) - debugging with tcpdump etc

Are there other Business PureFibre customers in Vancouver with working IPv6 as of October? It's not working here.


The Actiontek T3200M shows the same as this other user


My own router (EdgeRouter Pro) also doesn't get anything either. There are no responses to Router Solicitiations (as sent by the T3200M) or DHCPv6-PD/DHCPv6 solicit requests. I'll post comparative packet captures further in the thread.


Telus employees do claim IPv6 is being deployed:


There are some useful prior technical posts as well:

0 Likes
1 ACCEPTED SOLUTION

For now, it is one or the other. I know IPv6 / Server plans is on the roadmap in the future but there is no way I can provide specifics.

How do you wish to proceed? IPv6 connectivity with port blocking, or IPv4 only connectivity (with static IP) with no port blocking. 

View solution in original post

0 Likes
27 REPLIES 27

Unfortunately no. 

A move to a static IP service will indeed unblock those service ports, however there will not be a service configuration for IPv6. We do indeed have it on the roadmap just without specific timelines. Wish I had better news.

0 Likes

Wow, just want to post that this is exactly what I've been running into.  I switched from residential Internet 150 (which had both IPv4/IPv6 working perfectly - but dynamic) to get a static IPv4 address.  I then spent the next few days with Telus support and could not get IPv6 working.  I found the same things when debugging ipv6 dhcp - I can see my PD solicit messages being sent on the interface - but never see any return traffic.

 

A couple of comments:

1.  I'm using a Cisco ISR - so same commands as mentioned at the beginning of this thread.  They do indeed work fine - as long as you don't have a static IPv4 allocation on your account.

2.  I've been told the ONT's ports can be to provision additional 'services'.  Is there anyway Telus could provision a 2nd internet connection on another port - and ONLY allow IPv6 (as a stop-gap until other avenues are resolved)?  As the thread author - I want IPv6 for testing/development - but to me static IPv4 is more urgent at this point.  Come on Telus, it's 2018! - the future is friendly IPv6!

3.  Add me to the list of accounts wanting an 'IPv6 server' option!   I'm hoping this 'static IPv6' is still a /56 PD instead of a /64.  I like the /56 PD allocation as I can split that down into various /64 and use them as I want - behind my router/firewall.

 

 

0 Likes

Hey nooternal.

I'm pretty sure you chatted with our tech support team the other day as I had an agent reach out and ask a question on this topic. 

I'll add your account to the list of folks expressing interest for IPv6 over static IP plans. So far, it is still in single digit territory. This is a hot topic.  

0 Likes

Just banged my head against the wall for an hour wondering why neither dhcpcd nor wide-dhcpv6 could seem to get an IPv6 delegation and found this thread.  Created an account here just to reply.  🙂

 

So, without further ado:

- Telus business 300/300

- static ip package

 

Would love to also have static IPv6 ability.

 

Aug 13 19:21:29 void dhcpcd[47499]: em0: soliciting an IPv6 router
Aug 13 19:21:30 void dhcpcd[47499]: em0: soliciting a DHCPv6 lease
Aug 13 19:21:42 void dhcpcd[47499]: em0: no IPv6 Routers available  <- d'oh.

 

0 Likes

I figured I would add my voice to this as well. Business account with static address (which we need), and would love to have IPv6 with that.

 

Hopefully, we can get the number of people asking for this into the double-digits, then there will be dozens of us asking for this!

0 Likes

We have a few people subscribed to this thread, thanks for the input!

 

Jordan

 

0 Likes

Just signed up for Telus Business 300 with Static IP, installation was today, and after finding that IPv6 does not pick up an address via router advertisements I found this thread. Is IPv6 still not supported? I need the Static IP because I'm running Email and Web servers.

 

Thanks,

 

Joachim

0 Likes