Showing results for 
Show  only  | Search instead for 
Did you mean: 

IPv6 - IP address lost after ~30-90 minutes


Hi there,


I'm using a T3200M in bridge mode for my 300/300 PureFibre connection in Surrey, with my own hardware connected to port 1 of the TELUS modem.  I've also tried using a switch between the ONT and the TELUS modem and my own router.  The same issue happens as described below.


Specifically, I'm noticing that when the personal router picks up IPv6 addresses for IP and DNS, it functions normally for anywhere between 30 and 90 minutes, after which each and every IPv6 test site reports that no IPv6 address exists for my connection and it stops functioning.  For whatever reason, the v6 IP gets dropped, and as far as v6 is concerned, I'm dead in the water.  IPv4 works the entire time, regardless, otherwise I wouldn't be able to type this (lol).


Is there something that I need to have configured on my account for IPv6 to continue to function normally beyond the initial 30-90 minutes?  I'd like to use the connection for NAT-less gaming on my Xbox, and for obvious future-proofing reasons.  Rebooting the modem takes the v6 IP forever to re-bind, but when it does, it again only functions for 30-90 minutes before going AWOL.


Before you tell me that it's an issue on my personal router, I eliminated that as a source of the problem by connecting my PC to the TELUS modem directly on another port, and the same issue occurs: the v6 address drops and connectivity ceases.


Thanks for your attention!



No-one?...  I can't call in and get support, because they have no idea what I'm talking about, so... help please!

Community Power User
Community Power User

There have been a number of discussions about IPv6. Possibly this one is the best fit.


If you find a post useful, please give the author a "Kudo"

Thank you!  Yes, that is the exact issue.  Now how can we go about getting it fixed?

@Paul_C wrote:

No-one?...  I can't call in and get support, because they have no idea what I'm talking about, so... help please!

What router do you have as your own?
1) Router has to support Multicast, since TELUS uses IPTV

2) There should settings for that within Routers UI.
3) If you use Optik TV I don't recommend use your own router  as primary.

My own router here is irrelevant as the problem occurs even with my PC directly connected to the TELUS modem.


I'm not using my router for TV.  Optik is directly connected to the TELUS modem and doesn't go through my router; my router only supports my devices.



Since I can't call in for tech support (due to their lack of knowledge regarding IPv6), how can I go about getting support for this issue?


Is there someone I can contact that has the required level of knowledge and support ability that is needed to look into this?


Waiting days (!) on this forum hoping for an answer is not an option and shouldn't be our go-to solution for slightly more complicated issues.  And I absolutely refuse to pay for TELUS Tech Support Plus, since they don't know much beyond setting up e-mail accounts...

Community Power User
Community Power User

Possibly Telus’ social media team can assist you with your questions. Reach out to them via  Facebook Messenger or Twitter by tweeting @telussupport. They may be more likely interested to delve into the issue for you.

If you find a post useful, please give the author a "Kudo"

Any updates? fix?

Because all this would explain why I'm so much issues with mine too... and have to reboot my modem way too many times


An update:


With the help of their Twitter account, they were able to get someone in tech support to call me.  This tech worked with me on trying to find the source of the problem, but that problem isn't something with my personal hardware, nor is it something with their T3200M modem.  I asked him to escalate, and it's now sitting with the escalation manager, who has scheduled a more 'expert' field tech to come out and have a look this coming Saturday (Dec 15).  I assured him it's going to take someone in network engineering to figure this one out, since it's not the TELUS modem with the issue, but he explained they have to follow each step as per their process.


So... waiting for Saturday to tell the tech he's not going to be able to fix it 😉 .  Then once it's escalated further up into their main networking team, I'm hoping to get to someone who can diagnose the actual problem and then fix it properly.


In my view, and I'm no super-network-expert but I know a decent amount, the issue is with IPv6 routing, or something to do with how routes are updated and refreshed for IPv6, or the Nokia ONT itself, and it potentially affects anyone in the Lower Mainland, or BC, with a PureFiber connection (DSL seems to be ok).


The main issue is the result of there just not being enough IPv6 users for this to have become a big problem sooner.  From this thread and the other one, there only seems to be 3 people affected so far.  I'm sure if there were more, this would have been noticed before now.


Hope to have this fixed within the next 2-3 weeks, if I'm lucky.

So I have had fiber for a little over a week now and I can confirm I had this issue. Today I had a installer come to do a install and I had him swap the modem out and sure enough the problem has been gone since the swap. Hopefully it stays that way.

I guess I spoke too soon, For some reason my phone passes IPV6 tests but my computer seems to fail now. So I guess the issue is still on-going.

Any update since the tech came out Paul?

Hey all,


My apologies for not getting back/replying for so long.  I had cancelled the tech visit as it turned out it wasn't something they could fix, let alone understand.  As a result of being loud, and from the suggestion in this thread, I contacted TELUS via Twitter.  That woke them up 😉 .  Since then, I've been talking to a very helpful TELUS rep (shout out to Arlis!) that has helped to escalate my issue, and from what I was told by the TELUS Escalation Manager, the issue is within the Juniper RE's (Routing Engine) located at TELUS's network core locations throughout the city (I could be wrong about the specifics of that, suffice it to say it's an issue on TELUS's side).  I was told that Juniper was aware, and they were scheduled to issue a firmware update for their RE's, but there was no timeline for it to be done.  I tried to reach out to Juniper via Twitter, but of course, since I'm just a lowly consumer, I got no response.


TELUS was aware there was an issue on the Juniper end, but apparently the T3200 modem/router combo is also having an issue related to IPv6, which now requires a firmware update to correct.  That update is scheduled for some time in the next 6 months, without any firm date set.  The workaround, for now, is to use a T1200 modem, but that's not going to be doable for everyone, as some of the TV functionality is lost (T1200 can't do MOCA devices).


I can confirm the T1200 is working for me.  I have IPv6 functionality, and pass all IPv6 website tests that I've come across.  Command-line from the computer is pinging v6 addresses successfully as well, and the routes are no longer being dropped.


To get this done, you'll have to contact TELUS tech support.  When talking to them, you can refer to the following thread, which also has some more info in it if you want to read up:


That specific post, from Jordan Labelle (TELUS employee), explains what they found, and mirrors what my own testing uncovered, and also lays out the instructions I typed out above.  He says, in that post, to mention his post in that thread as a reference point for TELUS support to go ahead with the replacement.


Good luck, and hopefully they fix the problem on both the Juniper end, and the T3200's soon!