cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

How to Disable DHCP ?

souravsaha
Connector

Hi,

   I want to know, how can I disable DHCP service on my fiber router / modem ?

 

Thanks !!

12 REPLIES 12

xray
Guardian
Which router?

More importantly, why would you want to?

The fiber optic one. Dont know the model number - Sorry 

I want to use my Router / firewall for DHCP Service

Do you have Optik service? If not then just swap the routers.

No I don't have that service

did you figure out how to disable the dhcp?

No 
Tech Support said, not possible 

set the ip poll for a single ip address which is leased to the first device that connects to wifi hub . In this case it would be the router you mentioned

DrDanny
Just Moved In

I was able to disable DHCP on my Actiontec T1200H gateway/router, but the method is a little obscure. I did it so that I could use the device as a simple Access Point in order to broaden my wifi range. Briefly: login as admin to the device; go to LAN IP settings under the Advanced Setup tab; use your browser's javascript debug facilities to set a breakpoint on the source line that tests user_id in function 'hide_dhcpServerStat()'; reload the page and when it stops at the breakpoint, use the console to set user_id to 3; continue the code and when the page is rendered again you should see an option to disable DHCP. Disable it and reboot. Then you can connect the Actiontec to your main router LAN to LAN with an ethernet cable and it will serve wifi but allow the router DHCP to assign addresses. Do any of this at your own risk!

GRABBR
Neighbour

Finally got this solution to almost work!  I now see the disable DHCP option but when I do I get response "You can't disable DHCP server because the Optik TV is enabled."...

GRABBR
Neighbour

Nailed it! I had to add another breakpoint at line # 423 (as of firmware ver 31.164L.22) where it says if(optikTVenbl == '1' && dhcp_server[1].checked == true){

At that breakpoint I used console and typed in optikTVenbl == '0' and user_id = 1

DHCP is now disabled on my Actiontec T3200M.

I just got to this point but I always get a “You are an invalid user.” Message 😞

"use your browser's javascript debug facilities to set a breakpoint on the source line that tests user_id in function 'hide_dhcpServerStat()'; reload the page and when it stops at the breakpoint, use the console to set user_id to 3; continue the code and when the page is rendered again you should see an option to disable DHCP." - this worked for me...