Showing results for 
Show  only  | Search instead for 
Did you mean: 

A lot slower WIFI on Telus 100 using the new 2200h actiontec modem

Just Moved In

For so long, I never had any issues with Telus Internet. I had Telus 15, 25 then 50 and in all of those speeds, I have gotten pretty close to the advertised speed wired or wireless, using the older actiontec modem plus my netgear R700 router.


I was supposed to switch to Shaw 150 but Telus countered it with a good offer including Telus 100 (not fiber) for a year so I thought might as well try as that would be enough for me. First, Telus tech replaced the older modem saying it cannot handle 100mbps. It came with another device that is dual band as the modem is not dual band. I was not home when the writer has left and when I tested it from those Telus boxes, wired I was getting 95mbps to 99mbps down, wireless I was getting 30mbps to 60mbps, speeds are varying but definitely nowhere near the acceptable speeds as it is usually around 30-45mbps. I tried channel changing and none of them worked and results are almost the same with either band, and tests were done without any other devices connected and I am like literally next to the router. Now, I took out the dual band device hooked up to actiontec and plugged in my netgear r700 (nothing changed from the setup which I never had any issues with Telus) and it was only marginally giving me better results than Telus' own equipment. I was so lost why it would do that as nothing was changed, except the actiontec modem.


Went out and bought an Apple Airport Extreme and it was pretty much the same result as the netgear router. Again, on these routers, wired is perfectly fine 95mbps and up, but WIFI is also the same.


Even though prior to this, I never had any problems but I still scanned the neighbourhood and the 2.4ghz channel is not crowded in my area. And most especially not 5ghz as I was the only one using it in our area.


Anyone here that has Telus 100 and the same modem that is having the same problem?


Community Power User
Community Power User

Have you disabled the WiFi on the actiontec if using your own router?

Yes I have.

Community Power User
Community Power User

Change servers on (under settings change servers and select Burnaby, BC " In2net Network inc"

Run the test to that server and post the results using 2.4ghz and 5ghz.


Not sure which wireless devices you're trying to connect to your wifi, but they may be the weak link.  I was having the same issue when I switched to fibre 100 as some of the devices I was using over wifi weren't getting anywhere near the 100mbps speeds.  However, I noticed on my phone and tablet that the speeds were around 90mbps, which was perfectly acceptable.  Did a little digging and found that unless you have a wireless "N" compatible device (like my galaxy s6) you won't get anywhere near max speed.  The devices that I noticed ran slower were only wireless "B/G" compatible and will max out around 54mbps.  





I don't have the Internet 100, but have recently upgraded to Internet 50 and Optik TV. This required the installation of a T2200H router and the use of two telephone feed lines in a bonded configuration. One thing I noticed is that ping time (Okla Speedtest) was reduced with the bonded modem from about 5 ms to 12 ms. Download speed is about 10% better than the stated 50 Mbps service. I just tested an old HP laptop that runs wireless off the default configuration as Telus left it. It got 12 seconds ping time and 56 Mbps download. It would appear I am getting my full bandwidth on both wired ethernet and wireless. Can't test above 56 Mbps or course as Telus throttles the service to basically what you pay for. So all I can say is that the T2200H should be good for at least 56 Mbps on wireless.


I also have the Actiontec 2200H you are running with the bonded Internet 100 package, and can verify this issue with the WIFI.


For me it will perform to a maximum of 48Mbps right beside the AP with several different wireless devices, Including iPhone 6S, laptop with built in Intel AC NIC, as well as the Telus techs laptop. Specifically got a Asus USB-n53 that supports dual band, windows shows it trained up to the AP at 300-270Mpbs for the duration of the speed test but still the test yields 35Mbps...  He (the installer) actually commented on the fact that they usually do about half and he doesn't know why.

Have been waiting for a firmware update to fix this now since March, they pushed only one out since then and it had no affect on this issue.


I had one of the Linksys EA9200 Tri-Band routers which was almost 300 dollars and it made no difference in the speed with the Telus package it performed the same way as the WEB6000Q, that is limited to sub 50Mbps. This same router was giving me almost full 250Mbps on old Shaw plan on both my phone and laptop so I know that the hardware is capable of 100Mbps.


I did notice that when i got the Actiontec  2200H they left me one that had the yellow "refurbished" sticker on it...was not happy with this at all.


As a side note, I found if you toggle the switch on the back of your VEN501 access point to Client, you can use WPS to connect the Cisco access point to your WEB6000Q despite the fact that they have locked you out of the administrative settings. Keep in mind the security implications of WPS if you use it.


@Scoots Do you run your WEB6000Q hooked directly to your Actiontec or do you use the modem in bridged mode with a third party router?

I'm running on fibre with an Alcatel-Lucent modem to accept the incoming fibre optic line. From there the Aciontec is hooked up as a router. I am in an apartment and the Aciontec has no problem covering the 1400 sq ft without an extender so I never bothered setting it up.

I did have to play with the channels and frequency to minimize interference and haven't had any real issues. But I am on fibre optic so I'm not sure if the optic modem helps the Aciontec handle the load easier than when it has to act as a modem/router or as a modem when in bridge mode.

I see. I believe the OP is on the bonded DSL service (as am I) with the Actiontec running as the modem itself.


Wish we could get fiber here but in Edmonton it looks like they are doing all of the outer (rich peoples) areas of the city and anyone living in the older more central parts of the city is going to suffer for at least a couple years as there is no current planned date for its install.


I believe that the wifi speed issues are specifically related to the bonded DSL setup and the way the modem is handling it. The telus Installer that was out here seemed to be well aware of the issue.