Disable DHCP server Actiontec T3200M

Mango
Connector

Please add a way to disable the DHCP server in the Actiontec T3200M.  The T3200M is a great piece of hardware, with firmware that lacks the features of many other routers on the market today.  Thanks!

Status: New Idea
Category:
Comments
Community Manager
Community Manager

@Mango You do have the ability to turn on "Bridge Port 1" in the advanced settings and connect another router to LAN1 on the Actiontec. As this is an advance modem setting, it is not supported by our technical support team.  

Status changed to: Closed
Mango
Connector

Very true, however that is not related to what I was trying to do, which was configure the T3200M as an access point.

 

Can this be re-opened please?

Community Manager
Community Manager
 
Status changed to: New Idea
modd
Organizer

I'd like to add that I would like this option.

As I built my own router  and would just  add  the 5ghz to a dmz as to not mess up optik tv or use  info online about multicast / udp stuff you use for the tv.

xFitter255
Just Moved In

I'd like to re-open this issue. There must be some way to simply turn off DHCP on the T3200M. I can turn off the wireless, which would mean that I probably don't need the DHCP settings either. Why is there no way to simply turn off DHCP.

seffyroff
Just Moved In

Another vote for this.  This is such a simple requirement.  Those of us who know why we need this are comfortable with working out the details without Telus support, if you're concerned with increased support burden, stick it in the advanced options and let us break stuff Smiley Happy

 

Allent
Just Moved In

I also like this feature to be enabled. I think other service providers have the option enabled in their firmware. Please re-open the issue and give us some hope.

rc
Ambassador

A possible work around would be set the dhcp assignment range to be 1 address only and then use dhcp reservation to permanently assign the one address in the dhcp scope to a random ethernet address.

NewfieWannabe
Just Moved In

Definitely wishing to utilize this.  I do not have a spare router to use (my old Linksys DD-WRT is nowhere NEAR good enough to bridge this to it) but I want to just use this as the AP and let my personal Raspberry Pi do the DHCP and DNS for my local network.  I have it set for the DNS, but the DHCP it fails, since the Actiontec answers the DHCPRequest first.

Crownrai
Just Moved In

I would really like to see this option available on the T3200M.  I am also using internal DNS and DHCP services on a Raspberry Pi for my home.   My house has a family's worth of computers, tablets, consoles, media boxes and I have installed a ton of smart devices, switches, lights, and personal assistance (Echo, Google home etc.).

 

I need to be able to control and keep track of who gets which IP and what DNS settings they use. The T3200Ms DHCP and DNS services do not work well for this.

 

I have tried some of the suggested methods to force disable the DHCP service, fill up the leases addresses etc. but no go.  The T3200M still responds to DHCP requests no matter what I do.

 

xray
All-Star

The function is there, just hidden for normal users (us). I only looked for it out of curiosity. I have not tried turning it off so I don't know what will happen after.

 

Actiontec DHCP.png

 

I'm posting this because I'm guessing that if you know how to unhide it then you probably know how to manage your network with this off and will assume the responsibility for your actions. I will not tell you how to unhide it.

 

Friendly warning. For most users it's better that they don't change this as it could mess up Optik service and you may loose the ability to connect to the Actiontec with DHCP off. It's likely that TELUS won't support you if you mess things up. 

Crownrai
Just Moved In

I've un-hidden it as well and tried turning it off (It's nothing too secret, just use your browsers builtin Javascript debugger).  When you submit the changes, it just tells you "You are an invalid user" or something similar. 

 

I just switched to using a different router now.  Installed pfSense on an old PC with two network cards and it works way better than any ISP router ever will.

 

xray
All-Star

Looks like user_id needs to be 3 to be able to save the setting that disables the DHCP server. This is validated on the router regardless of what you do on the configuration page. I guess it was too good to be true.