Roaming Help!

Reply

This thread's discussion is locked. If it doesn't give you the information you need, head to its forum board for active discussions or to start a new discussion.

FutureFriendly
Good Samaritan

Im in Florida at the moment and everything is working but the internet on my phone. Does anyone know how I can fix it? I need to get my work emails ASAP and I don't have access on my laptop!!!

 

Highlighted
Most Helpful
BitMonkey
Resident

Hi FutureFriendly,

 

Sorry to see you haven't had luck getting on the internet while roaming, let's see if we can get it working for you; 

 

The first thing I'd like you to verify, is to ensure that data roaming is enabled in your device (most are disabled by default to prevent unwanted usage charges... We'll get into those in a bit)

 

 

if you are using an iPhone, the setting would be found under Settings/General/Cellular: Within this sub menu you will find "cellular data"  "Enable 3G/LTE" and "data roaming"

 

Please make sure both cellular data and data roaming are enabled as these are necessary for the internet to work in USA.

 

 

If you are using an android device, the path to get to the setting is as follows;

 

Menu or applications key / Settings, under the Wireless and Networks category, please choose More Settings then scroll to the bottom where you will find "Mobile networks" In this screen, both "Use packet data" and "Data roaming" need to have a green check mark in their corresponding boxes for the internet to work both at home and while roaming.

 

If you are using a blackberry on operating system 7.1 or older; \

 

From "all" icons, please select "Manage Connections", from this new screen, you will be able to select "Networks And connections" (under the Options and Statuses category) and then select "Mobile Network" Please ensure that both Data Services and "While roaming" are both set to ON.

 

On the newer blackberry platform (O.S. 10, ex Q10, Z10 etc.) please go to "settings" then "Network Connections" then choose "Mobile Network"  you will find "data services" this of course needs to be On, and also "Data services while roaming" should be set to "On"

 

Let's not forget Windows Mobile 8!

 

The path to the settings are; Settings/Cellular. Data connection must be turned On, and data roaming options must be set to "roam"

 

I hope this resolves your issue and allows you to spend some time enjoying the sunshine state!

 

 

Cheers!

 

-B.M.

 

P.s. Please make sure your account has been provisioned with one of our data roaming passports or combos before using it as the "pay per use" rate in the USA, as I type this message, is $5 per megabyte, adding a passport can save you a considerable amount even for a relatively short trip.