Forum Discussion
kmahmood
30 days agoNeighbour
Lets encrypt certificate renewal
I was Rogers home internet customer for a while and less than month moved to Telus. I run some home server setup with Proxmox. My Letś encrypt certificate renewal used to work fine. Now it's failing. I have no clue whatś happening.
I am sure someone have similar setup like me with Telus home internet. Any help greatly appreciated.
Thanks in advance.
4 Replies
- FuzzyLogic
Community Power User
Does manually renewing the certificate on the ipv6 hosts work?
Not sure what else to check:-(
- kmahmoodNeighbour
Unfortunately whether it is a new request or renewal, nothing works. Every time it fails with the same error.
- FuzzyLogic
Community Power User
I have a Synology NAS and use Let's Encrypt certificates. Aside from setting up port forwarding on my router for the ports I use on my NAS I don't recall having to do anything else to get this to work.
There may be something of use here:
- kmahmoodNeighbour
Thanks a lot for your reply.
I have multiple lxc containers. I am port forwarding for the domain that use’s IPv4. The ones failing are ipv6 only hosts. I have turned firewall off, checked externally to see if IPv6 port 80 and 443 are open, and I can access the letsencrypt acme challenge manually over port 80. Still lets encrypt reports some challenges failed (likely firewall).
I can access the site fine with a self signed certificate.
thanks